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CHAPTER 1 Introduction to BadgeDesigner
BadgeDesigner is a unique graphic design program used to create badge layouts for use with ID 
CredentialCenter software. Permanent badges can be printed on CR-80 badge card media while 
temporary badges can be printed on regular 8 ½” x 11” sheets of paper. 

Each BadgeDesigner badge layout can include the following types of elements or objects: text, 
graphics, barcodes, photos, signatures and shapes. Text and barcode objects can be linked to database 
fields. 

Each badge layout is stored in the access control database using a unique layout name. A layout 
consists of a set of layout property settings, a set of badge objects and a set of attribute settings for 
each object. All of these layout elements can be added and edited via BadgeDesigner’s easy-to-use 
graphical interface.

BadgeDesigner’s flexibility allows you to work with either English or Metric measurements, rounded 
to 1/1000th inches or 1/100th millimeters.

Conventions Used in this Documentation

• Where a term is defined, the word is represented in italics.

• Field names and file names are shown in bold.

• Menus and menu choices are shown in bold italics.

• Keyboard keys are represented in angle brackets. For example: <Tab>, <Ctrl>.

• Keyboard key combinations are written in two ways:

– <Ctrl> + <Z> means hold down the first key, then press the second

– <Alt>, <C> means press the first key, then press the second
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Window buttons on the screen are represented in square brackets. For example: [OK], [Cancel].

Getting Started

Passwords

OnGuard includes strong password enforcement, which checks the user’s password against password 
standards. This functionality is designed to enhance password security if single sign-on is not used. If 
single sign-on is used (automatic or manual), OnGuard does not enforce password standards. For 
more information on single sign-on, refer to Single Sign-On on page 15.

The system’s strong password enforcement also checks the Lenel database user’s password when 
logging into applications. Database user passwords apply only to Oracle and SQL databases. For 
information on changing your database password, refer to the Accounts and Passwords chapter in the 
Installation Guide.

Password Standards

When creating a strong password keep the following guidelines in mind:

• Passwords cannot be blank.

• Passwords cannot be the same as the user name (e.g. SA, SA).

• Passwords cannot be Lenel keywords.

• Although not required, your password should contain numbers, letters, and symbols. Spaces are 
also acceptable. (e.g. August 18, 2002).

• OnGuard user passwords are not case-sensitive.

• Database passwords conform to the rules of the specific database being used; passwords in SQL 
Server and Oracle are case sensitive.

•  The maximum value for a strong password is 127 characters. The minimum value is 1.

Notes: For Oracle databases the following account username and passwords are not allowed to 
be used together:

System and Manager

Internal and Oracle

Sys and Change_On_Install

Change User Passwords

User passwords are checked every time a user logs into any application. After a user logs into an 
application he/she can change his/her user password.

1. From the Layout menu select Change Password.

2. The Change Password window displays. Enter your old password and new password in the 
appropriate fields. Refer to the Password Standards on page 12 for guidelines in choosing a 
secure password. 

3. A message confirms that you have successfully changed your password.

4. Click [OK].
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Note: If you get a weak password message the next time you log into the application, carefully 
read the message. It may be telling you that your database password is weak and not 
your user password. To change your database password, refer to the Accounts and 
Passwords chapter in the Installation Guide.

Error Messages

Read weak password messages/warnings carefully to avoid confusion about whether your user 
password or database password is weak.

If you have a weak database password you will receive a warning every time you log into any 
application, until you change your database password. Although it is not recommended, you can 
acknowledge the warning and continue working in the application. This table describes the password-
related error messages that may be generated and which password you need to correct.

• To correct the database password, refer to the Accounts and Passwords chapter in the Installation 
Guide.

• To correct the user password, select a password that meets the standards specified in Password 
Standards on page 12.

Accounts

Anyone who wishes to use OnGuard applications must enter a user name and password in order to 
access the software. The System Administrator should create a unique account for each user of the 
applications. The System Administrator can also, for each user, create a list of permissions, which 
specifies precisely which screens, fields, and buttons the user can access.

During initial installation of the application, default accounts are created. These include:

Warning message
Password to 
correct

Database password violations: Your password 
is a keyword that is not allowed. It is highly 
recommended that you change your password 
to meet our minimum password standards.

Database

Your password cannot be blank. Please enter a 
password.

User

User password violations: Passwords cannot 
be the same as the user name.

User

Your password is a keyword that is not 
allowed.

User

User name Password Type

sa sa system account

admin sample

user sample

badge sample
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These are provided as samples. You may change the passwords and use the accounts, or remove them. 
The exception to this is the system account, SA. By definition this account has permission to do 
anything in the system. A user with system access has unlimited access to the application. You cannot 
delete or change the system account except to modify the password, which you are strongly 
encouraged to do as soon as possible to discourage unauthorized use.

The first time you log into OnGuard to configure the application, you should log in as SA and your 
password should be SA.

Log In

This procedure describes how to log in without using single sign-on. For a description of single sign-
on, refer to Single Sign-On on page 15. To log in using single sign-on, refer to Configure Single Sign-
On on page 16.

1. In Windows, start the desired application.

For more information, refer to “Using OnGuard on Supported Operating Systems” in the 
Installation Guide.

2. Your system may be configured to prompt you to select a database to log into. If it is not, proceed 
to the next step. If it is:

a. In the Database drop-down, all ODBC system databases currently defined on your 
computer are listed. Select the database that you wish to use for your application.

b. Click [OK].

3. The Log On window displays.

a. In the User name field, type the user name assigned to you. When logging in for the first 
time, your user name is SA.

b. In the Password field, type the password assigned to you. When logging in for the first time, 
your password is SA. Note that the characters you type do not appear in the field. Instead, for 
each character you type, an “*” displays. This is intended to protect against unauthorized 
access in the event that someone else can see the screen while you type.

IMPORTANT: After logging in for the first time, you are strongly encouraged to modify the 
password for the system account as soon as possible to discourage 
unauthorized use.

c. In the Directory field, select the directory that you wish to log into. For user accounts not 
using single sign-on, the default is “<Internal>.”

d. Select the Remember user name and directory checkbox if you want the values you just 
entered in the User name and Directory fields to automatically be selected the next time 
that you log in.

e. Click [OK].

4. Your system may be configured to prompt you to confirm that you are authorized to use the 
application. To accept the terms of the authorization warning click [Yes].

5. If segmentation is not enabled, skip this step. If segmentation is enabled:

a. The Select Segment window opens. Select the segment you wish to log into.

b. Click [OK].
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Single Sign-On

Single sign-on simply means logging into OnGuard with the same user name and password that you 
use to log into Windows or logging into OnGuard using an LDAP user name and password for 
authentication. LDAP (Lightweight Directory Access Protocol) is a software protocol that enables 
you to locate businesses, people, files, and devices without knowing the domain name (network 
address).

Notes: Windows Authentication should be used when single sign-on is desired. In other 
scenarios, use Anonymous Authentication. For more information, refer to:

http://support.microsoft.com/kb/258063

and

http://msdn.microsoft.com/en-us/library/aa292114%28VS.71%29.aspx.

Single sign-on allows scripts using the DataConduIT API to authenticate. These scripts will be run 
under a Windows account. The account that is making the call to the API can be obtained easily this 
way, and the script can be restricted to those actions that the user is permitted to perform (using 
standard OnGuard permissions).

Note: The use of the explicit username and password for directory authentication to Windows 
is strongly discouraged. It is recommended that you do not store Windows passwords in 
the OnGuard system, since OnGuard uses reversible encryption and Windows does not. 
If explicit authentication is required, you should use an account that has view only 
permission to the directory in question.

It is possible to assign both an internal account and one or more directory accounts to a single user. 
Assigning both types of accounts increases the flexibility of the system during the authentication 
process. If the directory service is down or cannot be found from the workstation where the user is 
logging on, that user can instead use the internal account. Using both types of accounts means that 
you need to manage the internal account user names and passwords in addition to managing the 
directory accounts.

IMPORTANT: Allowing a user to log on in multiple ways increases the probability that the 
user's access to the system could be compromised. It is recommended that you 
standardize on either internal or directory accounts, but not both.

There are cases where assigning both an internal account and a directory account to a user may make 
sense. In a system where directory accounts are predominantly used, you may also assign an internal 
account to a user who needs to access the system from locations where the directory service is 
unavailable. If internal accounts are predominantly used, you may want to assign a directory account 
to a user so that the user does not need to enter in a password to log on.

Directory Accounts

To log into OnGuard using single sign-on, a user name, password, and directory are required. A 
directory is a database of network resources, such as printers, software applications, databases, and 
users. The following directories are supported by OnGuard: Microsoft Active Directory, Microsoft 
Windows NT 4 Domain, Microsoft Windows Local Accounts, and LDAP.

Automatic and Manual Single Sign-On

When a user account is configured for single sign-on, the user can log into OnGuard automatically or 
manually.
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For example, with automatic single sign-on, users simply start OnGuard and they are automatically 
logged in under their Windows account and directory. 

With manual single sign-on, users must manually enter their Windows or LDAP account information 
(user name and password). Users also have the option of selecting a different configured directory.

If single sign-on is not used, users manually enter a user name and a password that is different from 
their Windows or LDAP password. The directory is hard-coded to refer to the internal OnGuard user 
directory.

Notes: Manual single sign-on can be used with the following directories: Microsoft Active 
Directory, Microsoft Windows NT 4 Domain, and LDAP.

Automatic single sign-on can be used with every directory supported by OnGuard 
except LDAP because it doesn’t provide all the account information required.

Configure Single Sign-On

By default, user accounts do not use sign-on. To configure single sign-on the System Administrator 
must add a directory and link a user account to the directory.

Notes: For more information, refer to “Add a Directory” in the Directories folder chapter of the 
System Administration or ID CredentialCenter User Guide.

For more information, refer to “Link a User Account to a Directory Account” in the 
Users folder chapter of the System Administration or ID CredentialCenter User Guide.

Log In Using Automatic Single Sign-On

Automatic single sign-on is supported with Windows domain accounts.

1. In Windows, start the desired application.

For more information, refer to “Using OnGuard on Supported Operating Systems” in the 
Installation Guide.

2. Your system may be configured to prompt you to select a database to log into. If it is not, proceed 
to step 3. If it is:

a. In the Database drop-down, all ODBC system databases currently defined on your 
computer are listed. Select the database that you wish to use for your application.

b. Click [OK].

3. If your Windows account is linked to a user, a message will be displayed that says, “Attempting 
to automatically log you on using your Windows account. To bypass this, hold down SHIFT.” To 
automatically be logged in, do nothing.

4. Your system may be configured to prompt you to confirm that you are authorized to use the 
application. To accept the terms of the authorization warning, click [Yes].

5. If segmentation is not enabled, skip this step. If segmentation is enabled:

a. The Select Segment window opens. Select the segment you wish to log into.

b. Click [OK].

Log In Using Manual Single Sign-On

Both users who want to log into OnGuard using an LDAP user name and password for authentication 
and users who want to log in using a Windows domain account can do so using manual single sign-
on. 
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Troubleshoot Logging In
1. In Windows, start the desired application.

For more information, refer to “Using OnGuard on Supported Operating Systems” in the 
Installation Guide.

2. Your system may be configured to prompt you to select a database to log into. If it is not, proceed 
to step 3. If it is:

a. In the Database drop-down, all ODBC system databases currently defined on your 
computer are listed. Select the database that you wish to use for your application.

b. Click [OK].

3. If your Windows account is linked to a user, a message will be displayed that says, “Attempting 
to automatically log you on using your Windows account. To bypass this, hold down SHIFT.” 

To manually login or to login using a different user name and password, hold down the <Shift> 
key. The Log On window opens.

a. In the Directory field, select the directory that you wish to log into. The default is 
“<Internal>.”

b. In the User name field, type the Windows user name assigned to you. Do not enter the 
domain\user name just enter your user name.

c. In the Password field, type the Windows password assigned to you.

d. Select the Remember user name and directory checkbox if you want the values you just 
entered in the User name and Directory fields to automatically be selected the next time 
that you log in.

e. Click [OK].

Note: Your system may be configured to prompt you to confirm that you are authorized to use 
the application. To accept the terms of the authorization warning, click [Yes]. 

4. If segmentation is not enabled, skip this step. If segmentation is enabled:

a. The Select Segment window opens. Select the segment you wish to log into.

b. Click [OK].

Troubleshoot Logging In

If you attempted to log in and were unable to do so, make sure that the following conditions have 
been met:

• You entered a correct user name/password and specified the correct directory.

• If your system is configured to display an authorization warning, you accepted the terms.

• A valid license is installed.

• You have permission to use the application.

• If you attempted to log in and were unable to do so, make sure the following conditions have 
been met:

– You entered the correct user name and password for the selected directory of a user with 
permission to use the application.

– If the system is configured to display an authorization warning, then you accepted the terms.

– Verify your License Server settings (refer to the Configuration Editor appendix in the 
Installation Guide). The LS License Server service must be started on the specified Host.

– Log into the License Administration application to verify a valid license is installed.
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– Software based licenses must be activated.

– USB licenses must have License Key Drivers installed.

– If using single sign-on, ensure the pc user you are logged in as is linked to an internal 
OnGuard user through an operational directory.

Assigning Directory and Internal Accounts to the User

It is possible to assign both an internal account and one or more directory accounts to a single user. 
Assigning both types of accounts increases the flexibility of the system during the authentication 
process. Meaning, if the directory service is down or cannot be found from the workstation where the 
user is logging on, then the user can use the internal account instead.

However, using both types of accounts means that you need to manage the internal account user 
names and passwords in addition to managing the directory accounts. Allowing a user to log on in 
multiple ways increases the probability that the user’s access could be compromised. For that reason, 
it is recommended that you standardize on either internal or directory accounts, but not both.

There are cases where assigning both an internal account and a directory account to a user may make 
sense. In a system where directory accounts are predominantly used, you may also assign an internal 
account to a user who needs to access the system from locations where the directory service is 
unavailable. If internal accounts are predominantly used, you may want to assign a directory account 
to a user for that user's convenience, so that the user does not need to enter in a password to log on.

Set User Permissions for BadgeDesigner Access

The System Administrator should create a unique account for each user. The System Administrator 
can also create a list of permissions, which specifies precisely which screens, fields and buttons each 
user can access. BadgeDesigner permissions are set via the System Administration or ID 
CredentialCenter software application.

1. Log into System Administration or ID CredentialCenter.

2. From the Administration menu select Users.

3. Refer to the following table for additional navigation instructions and settings you should apply 
For more information, refer to the Configure User Permissions in the System Administration 
User Guide.

Required Permissions for BadgeDesigner

BadgeDesigner 
operation/feature 
enabled Navigation sequence  Settings required

ALL BadgeDesigner 
Operations

System Permission Groups tab > 
Software Options - Applications > 
BadgeDesigner

AND

Cardholder Permission Groups tab > 
Badges > Badge types and layouts

 

AND
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Log Out of the Application
Log Out of the Application

1. To log out of the application, select Log Off from the Layout menu.

2. If a layout is open, it automatically closes.If there are unsaved changes you will be asked if you 
want to save the changes before the map closes. 

Note: After you log out of the application the main window remains opened but most of the 
toolbar and menu options are dimmed. To access all the application’s features you must 
log in again.

• Database Login

• New Layout, Export 
Layout

Cardholder Permission Groups tab > 
Badges > Badge types and layouts

Save Layout and Rename 
Layout

Cardholder Permission Groups tab > 
Badges > Badge types and layouts

Save Layout As Cardholder Permission Groups tab > 
Badges > Badge types and layouts

OR 

Note: If permission to “Modify” is given (and not “Add”), the user 
will only be able to perform the “Save Layout As” operation 
to overwirte existing layouts.

Import Layout Cardholder Permission Groups tab > 
Badges > Badge types and layouts

Delete Layout Cardholder Permission Groups tab > 
Badges > Badge types and layouts

Multimedia Capture 
window (Capture layout 
graphic via FlashPoint/
MCI video or WDM video)

Cardholder Permission Groups tab > 
Capture > Photo

Multimedia Capture 
window (Capture layout 
graphic via digital camera 
or scanner)

Cardholder Permission Groups tab > 
Capture > Chromakey

Multimedia Capture 
window (Image 
processing)

Cardholder Permission Groups tab > 
Capture > Image processing

Multimedia Capture 
window (Effects gallery 
tab)

Cardholder Permission Groups tab > 
Capture > F/X gallery

Required Permissions for BadgeDesigner (Continued)

BadgeDesigner 
operation/feature 
enabled Navigation sequence  Settings required
BadgeDesigner User Guide 19



Introduction to BadgeDesigner

20
Exit the Application

The main window can be closed using either of the following methods:

• Select Exit from the Layout menu.

• Double-click the icon located in the upper left corner of the title bar. If you are prompted to log 
off click the [Yes] button.

• Single click the icon located in the upper left corner of the title bar and select Close. If you are 
prompted to log of click the [Yes] button.

• Click the close button in the window’s upper right corner. If you are prompted to log of click the 
[Yes] button.
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CHAPTER 2 BadgeDesigner Main Window
Menus and Toolbars

The menu bar is a horizontal list of options that appears at the top of the main window. Each option 
has a pull-down menu.
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A toolbar is a strip of buttons that is positioned by default just below the menu bar on the main 
window. You can:

• Change toolbars from anchored to floating:

The toolbars are anchored by default. Anchored toolbars are displayed in horizontal rows below 
the menu bar. Anchored toolbars can be changed to floating toolbars, which allows the toolbar to 
be repositioned anywhere in the main window. For more information, refer to How to Use the 
Toolbars on page 27.

• Control which toolbars are displayed:

Which toolbars are displayed is determined in the Toolbars sub-menu of the View menu. By 
default, all toolbars are displayed. You can control which toolbars are displayed by selecting or 
deselecting the toolbar entries. For more information, refer to How to Use the Toolbars on 
page 27.

Menus

The following is a description of the pull-down menu options available from the main menus and the 
corresponding toolbar button.

Layout menu

New

 Creates a new badge layout.

New From Template...

 Opens the Load Template window for you to choose the print media template you are 
using for the badge design.

Open

 Opens an existing badge layout.

Gallery
Displays thumbnail views of all layouts in the database. Opens the Select Graphic from 
Database window, from which badge layouts can be opened, renamed, deleted, imported or 
exported.

Close
Closes the badge layout in the active BadgeDesigner window.

Save

 Saves the active badge layout to the database.

Save As

 Saves the active badge layout with a new name.
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Update Database Field List
Re-queries the database for new fields defined in FormsDesigner and new values defined 
using List Builder (located in System Administration or ID CredentialCenter). The Sample 
Data view is then updated with this information.

numbered options
Displays a history of the last four layouts previously opened. Select the option to open it.

Log On

 Opens the BadgeDesigner Login window, enabling you to log back in to the 
BadgeDesigner database.

Change Password
Opens the Change Password dialog, enabling you to change your password (you must have the 
corresponding system level permission to do so.)

Log Off

 Logs you out of the BadgeDesigner database.

Exit
Exits the BadgeDesigner application.

Edit menu

Cut

 Cuts selected objects from the badge layout.

Copy

 Copies selected objects onto a clipboard.

Paste

 Pastes objects (which are currently on the clipboard) into the badge layout.

Delete
Deletes selected objects from the badge layout.

Insert
Adds objects to the badge layout. The following types of objects can be added to a badge 
layout: barcodes, photos, signatures, circles, ellipses, graphics, magnetic stripes, rectangles, 
round rectangles (rectangle with rounded corners), text and smart chip contacts.

Magnetic stripe and smart chip contacts are designed to block out printing of any objects that 
overlap them. 

Rename Object
Renames selected objects in the badge layout.
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Object Text
Launches the Text Object dialog box.

Select Graphic
Launches the Gallery window.

Select Previous
Selects the object that is before the currently selected object in the badge layout’s object layer 
order. For more information, refer to Object Layer Numbers on page 58.

Select Next
Selects the object that is after the currently selected object in the badge layout’s object layer 
order.

Select All
Selects all objects in the badge layout.

Deselect All

 Deselects all objects in the badge layout.

Move Forward

 Moves the selected object up one layer in the badge layout’s object layer order.

Move Back

 Moves the selected object back one layer in the badge layout’s object layer order.

Move to Front

 Moves the selected object to the highest layer in the badge layout’s object layer order.

Move to Back

 Moves the selected object to the lowest layer in the badge layout’s object layer order.

View menu

Toolbars
Toggles (on/off) the display option for each of the following toolbars: Layout, Drawing, 
General Formatting, Graphic Formatting, Text Formatting, and Barcode Formatting.

Status Bar
Toggles (on/off) the display option for the BadgeDesigner status bar.

Layout Properties
Opens the Layout Properties window, from which layout specifications such as badge size, 
orientation and unit of measure are set.
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Object Properties

 Opens the Object Properties window for the selected object in layout view. Allows you 
to edit the properties of the badge object(s).

Options
Launches the Options dialog, where you can configure behavior for your workstation.

Window menu

Cascade
Displays each open badge layout in separate windows, one on top of the other, with the active 
layout in the topmost window.

Tile Horizontally
Displays each open badge layout in separate windows, one under the other, with the active 
layout in the uppermost window.

Tile Vertically
Displays each open badge layout in separate windows, next to the other, with the active layout 
in the left most window.

Close All
Closes all open badge layouts.

Switch Panes
Switches back and forth between the Layout view, the Sample Data view and the Object List 
view.

numbered options
Displays the titles of all the badge layouts currently open. A checkmark is displayed next to 
the active layout.

Help menu

Contents
Starts BadgeDesigner’s online help application.

Search
Allows the online help to be searched for a specific topic.

About BadgeDesigner
Displays software version and copyright information for BadgeDesigner.

Toolbars

The BadgeDesigner window contains six toolbars. Each toolbar contains a set of buttons that are used 
to perform specific BadgeDesigner application functions. Most toolbar buttons perform the same 
function as a menu command on one of the BadgeDesigner main menus. When BadgeDesigner is 
started, these toolbars are “docked,” or positioned, underneath the menu bar.
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Layout toolbar

Contains buttons to create, open and save badge layouts as well as cut, copy and paste objects. For 
more information, refer to Chapter 4: Create, Open and Save Layouts on page 37.

Drawing toolbar

Contains buttons to add and select badge objects in the badge layout as well as move badge objects. 
For more information refer to Chapter 6: Add, Select and Delete Badge Objects on page 57. and refer 
to Chapter 7: Move, Rename, Resize, and Rotate Badge Objects on page 67..

General Formatting toolbar

Contains buttons to set fill and border attributes for badge objects and to set background transparency 
and scale attributes for photo, signature, graphic and text objects. For more information, refer to 
Chapter 8: Set General Formatting Attributes on page 73.

The General Formatting toolbar also contains a button to modify the text value for text objects. For 
more information, refer to Insert Fields into Text Objects on page 89.

Graphic Formatting toolbar

Contains buttons used to set ghosting, aspect and tiling attributes for photo, signature and graphic 
objects and to set pen width and color attributes for signature objects. For more information, refer to 
Chapter 9: Set Graphic, Photo and Signature Attributes on page 79.

Text Formatting toolbar

Contains buttons used to set font, font point size, font style, display case, color, word wrap and 
maximum character attributes for text objects. For more information, refer to Set Text Attributes on 
page 85.

Barcode Formatting toolbar

Contains buttons used to set rotation and type attributes for barcode objects. For more information, 
refer to Chapter 12: Set Barcode Attributes on page 101.
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How to Use the Toolbars

BadgeDesigner Views

The BadgeDesigner main window contains three work areas or views that are used to display 
information about badge objects. The Layout view displays each badge object in the format, position 
and size in which it will be printed. The Object List view displays the badge objects in list form (in 
order by object name). The Sample Data view contains data fields and sample data. These views are 
updated simultaneously - when an object is selected in the Layout view, it is automatically selected in 
the Object List view and vice-versa. 

Objects can be selected, renamed and deleted using the Layout or Object List views, but objects can 
be added using the Layout view only.

If you want to: Procedures:

Display the name of a toolbar 
button (tool tip)

Point to the toolbar button with the mouse (without clicking).

Use a toolbar button to 
perform a command or 
function

Click the toolbar button with the left mouse button.

Change a toolbar from 
“anchored” to “floating” or 
from “floating” to “anchored”

Double-click any empty area of the toolbar. 

Rearrange floating toolbars 1. Click in an empty area of the toolbar.
2. Drag the toolbar to its new position.

3. Release the mouse button to anchor it.

Rearrange anchored toolbars 1. Click in an empty area of the toolbar.
2. Drag the toolbar to its new position.

3. Release the mouse button.

Hide or display a toolbar 1. From the View menu select Toolbar. 
2. A sub-menu displays, containing the name of each 

BadgeDesigner toolbar. Click the desired toolbar name. (A 
checkmark appears next to each toolbar that is not currently 
hidden.) Toolbars can be toggled in order to be displayed or 
hidden.
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Layout View

The Layout view displays the badge layout template - it is the main work area in which the badge 
layout is actually created. Objects are added to the badge layout template via the Layout view.

 

Ruler
Horizontal and vertical guides used to help position and size objects in the badge layout 
template. Top-left intersection is 0,0. Unit of measure is inches or millimeters. 

To set the unit of measure select Layout Properties from the View menu. Click the Editor tab 
and set the unit of measure in the appropriate field. 

Page Margin
Non-printing guides used to show where the top, bottom, left and right page margins are set 
for the badge layout. 

To set the Page Margin select Layout Properties from the View menu. Click the Layout tab 
and set the page margins in the appropriate fields.

Grid
Non-printing dotted lines used to help position and size objects on the badge layout template. 
A grid can be used to automatically align or “snap” objects to nearest grid line or the grid can 
be hidden when not needed. 

To change the grid settings select Layout Properties from the View menu. Click the Editor tab 
and select the appropriate check boxes.

Right-click Menu Options in Layout View

If you right-click while your cursor is in Layout view the following shortcut options are available:

Layout view

Sample Data 
view

Object List 
view
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View Object Text
Opens the Text window, from which static text data and variable database data specifications 
can be set for selected text and barcode objects. The text or barcode object must be selected for 
this right-click option to be available.

Select Graphic
Opens the Select Graphic from Database window, from which badge layouts can be opened, 
renamed, deleted, imported or exported. A graphic must be selected for this right-click option 
to be available.

Rename
Allows you to rename an object listed in the Badge Objects view. An object must be selected 
for this right-click option to be available.

Cut
Removes or cuts the object from the layout view and places it on a clipboard. An object must 
be selected for this right-click option to be available.

Copy
Copies an object onto a clipboard. An object must be selected for this right-click option to be 
available.

Insert
Adds objects to the badge layout. The types of objects include: text, graphics, barcodes, 
photos, signatures, rectangles, round rectangles, circles and ellipses.

Paste
Pastes objects (which are currently on the clipboard) into the badge layout.

Delete
Deletes selected objects from the badge layout.

Database
Saves the badge layout to the database.

Properties
Opens the Layout Properties window, from which specifications such as badge size, 
orientation and unit of measure are set. For more information, refer to Chapter 5: Set Layout 
Properties and View Options on page 41.

Object List View

The Object List view is helpful for selecting objects that have been placed behind other objects 
(layered) in the badge layout template. The Object List view displays small object icons and object 
names for each object in a badge layout. Objects are listed in alphabetic order by object name. 

If you right-click with the cursor in Object List view, the same options are available as when you 
right-click in Layout view. For more information, refer to Right-click Menu Options in Layout View 
on page 28.
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Sample Data View

The Sample Data view displays the various fields and sample cardholder data that can be used in the 
badge layout. Its function resembles the Sample Field Data tab in the Layout Properties folder. For 
more information, refer to Sample Field Data Form on page 50.

.

Field
Displays the external field names for each standard cardholder field and custom UDF (user-
defined field) in the BadgeDesigner database that can be linked to a badge object.

Sample Data
Displays sample data values for each BadgeDesigner database field. You can also edit the 
default values. Highlight the sample, edit the data as required, then press <Enter>, <Arrow 
Up> or <Arrow Down> to set the value.

Status Bar

The BadgeDesigner window contains a Status Bar that displays the size and location information of 
selected objects in the badge layout template.

Message box
Displays information about the selected menu command or toolbar button or about a function 
in progress.
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Status Bar
Top Left Coordinate box
Displays the offset, in inches or millimeters, of the top left corner of the selected object in the 
badge template layout.

Bottom Right Coordinate box
Displays the offset, in inches or millimeters, of the bottom right corner of the selected object in 
the badge template layout.

Size box
Displays the height and width, in inches or millimeters, of the selected object.

Hide/Display the BadgeDesigner Status Bar

From the View menu select Status Bar to hide or display the status bar.

Note: A check mark appears next to the Status Bar menu option if the status bar is not 
currently hidden.
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CHAPTER 3 Design a Badge Overview
The BadgeDesigner main window opens automatically when the BadgeDesigner application starts. 
From this window you can create badge layouts and edit them.

Designing a Badge

Use the following procedures for designing a badge.

Create and Save Badge Layouts

The first step in creating a new badge layout is to open a new layout. Once a new layout is open, it can 
be assigned a unique badge layout name and saved to the database. For more information, refer to 
Chapter 4: Create, Open and Save Layouts on page 37.

Set Layout Properties

The next step is to set the layout specifications or layout properties. Layout properties include badge 
size, orientation, unit of measure specifications and optional magnetic stripe specifications. For more 
information, refer to Chapter 5: Set Layout Properties and View Options on page 41.

Using Avery Badge Templates

BadgeDesigner supports the use of Avery print media in the badge design process and a number of 
different options are available for you to choose from.

To use Avery badge templates in BadgeDesigner:

1. From the Layout menu, select New From Template. The Load Template window is displayed.

2. Choose the template that matches the print media you are using.

3. Click [OK].

The following Avery products are compatible with BadgeDesigner:

• Avery® 2940 Self-Adhesive Name Badge Labels™ 
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• Avery® 2941 Self-Adhesive Name Badge Labels™ 

• Avery® 2942 Clean Edge Name Badges, Business Card Size™ 

• Avery® 2943 Clean Edge Name Badges, Business Card Size™ 

• Avery® 2944 Clean Edge Name Badges, Convention Size™ 

• Avery® 2945 Clean Edge Name Badges, Convention Size™

• Avery® 2946 Laminated Name Badges & Self-Adhesive Clips, Business Card Size™ 

• Avery® 2951 Laminated Name Badges & Self-Adhesive Clips, Business Card Size™ 

• Avery® 2947 Fold & Clip Name Badges, Landscape, Business Card Size™

• Avery® 2948 Fold & Clip Name Badges, Portrait, Business Card Size™

• Avery® 2949 Fold & Clip Name Badges, Landscape, Convention Size™

• Avery® 2960 Direct Thermal Self-Adhesive Name Badge Labels™ (Roll)

• Avery® 2961 Direct Thermal Fold & Clip Name Badges, Landscape™ (Roll)

• Avery® 2962 Direct Thermal Fold & Clip Name Badges, Portrait™ (Roll)

• Avery® 2990/2992 Label for Access Control Card - Landscape

• Avery® 2990/2992 Label for Access Control Card - Portrait

• Avery® 2991/2993 Label for Access Control Card - Portrait

• Avery® W5000 Plastic card + Dry peel Clear Media - Landscape

• Avery® W5000 Plastic card + Dry peel Clear Media - Portrait

• Avery® W7100/W9100 Name Badge Media with Hole - Two-Sided - Landscape

• Avery® W9150 Name Badge Media without Hole - Two-Sided - Landscape

• Avery® W9150 Name Badge Media without Hole - Two-Sided - Portrait

• CR-80

• CR-90

• CR-100

Managing Badge Layouts

After the badge layout is created you can customize the layout to meet your specific needs. You can 
move, rename and resize badge layouts, set object attributes and even program badge objects.

The following types of badge objects can be added to a badge layout: text, graphics, barcodes, 
cardholder photos, cardholder signatures, magnetic stripes, smart chip contacts and various shapes. A 
badge layout can contain any combination, size and number of these object types.

When an object is added to a badge layout, it is automatically assigned a set of object attributes 
including size, position, fill style, fill color, border style, border color and width. These object 
attributes can be edited at any time during the badge design process. For example, each object is 
automatically assigned an object name. However, you may rename any object, to assign your own 
meaningful names to the objects in your badge layout.

When you program a badge (template), you select a badge object attribute to automatically populate 
with cardholder specific information when the badge is printed. For example, you can program a 
badge template so that when a badge is printed, an object attribute such as the cardholder’s 
department prints a different color depending on the department they are in.
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CHAPTER 4 Create, Open and Save Layouts
BadgeDesigner layouts are created via the Layout view and saved in the BadgeDesigner database.

Create a New Badge Layout

To create a new BadgeDesigner badge layout choose one of the following:

• Menu command: Layout >New

• Shortcut key: <Ctrl>+N

• Toolbar button: 

Open an Existing Badge Layout

1. To open an existing badge layout choose one of the following:

• Menu command: Layout > Open

• Shortcut key: <Ctrl>+O

• Toolbar button: 

2. The Open Layout window displays a list of the layout names for all existing badge layouts in the 
BadgeDesigner database. Select the name(s) of the badge layout(s) to open and click the [OK] 
button.

Note: You can use the <Shift> key or the <Ctrl> key to select multiple layouts simultaneously. 
Each layout opens in its own window.
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‘

Save a Badge Layout

1. To save a badge layout to the database choose one of the following:

• Menu command: File > Save or Save As

• Shortcut key: <Ctrl>+S or <Ctrl>+A

• Toolbar button:  or 

2. The Save Layout window or Save Layout As window opens. Type the desired badge layout name 
in the Layout name field and click [OK].

Close a Badge Layout

1. To close a badge layout choose one of the following:

• Menu command: Layout > Close

• Shortcut key: <Ctrl>+<F4>

2. If no changes have been made to the badge layout since the last time it was saved, the layout 
closes.

If changes have been made to the layout since the last time it was saved to the database, a 
message window opens, from which one of the following options must be chosen:

• [Yes] to continue the close function, abandoning the unsaved changes.

• [No] to cancel the close function, so that the layout can be saved.
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Working with Multiple Layouts
Working with Multiple Layouts

BadgeDesigner allows you to have multiple badge layouts open at once, each in their own window. 
Every time a new badge layout is opened, it becomes the “active” layout and is assigned a window 
number. For example, the first layout opened is assigned window one, the third window opened is 
assigned window three.

If you are working with multiple open layouts, BadgeDesigner enables you to easily switch between 
the different layout windows as well as minimize and arrange all of the windows.

Switch Between Open Layouts 

To switch to another open badge layout, one layout at a time, press <Ctrl> + <Tab>. The next open 
badge layout window is made active. 

Note: The next window is the one that was most recently active. 

To switch to a specific open badge layout:

• From the Window menu, choose the numbered menu command for the window number of the 
appropriate badge layout. (The Window menu contains a numbered menu command for each 
open layout.) The selected badge layout is made active. 

Automatically Minimize and Arrange Open Layouts 

BadgeDesigner provides three different options for automatically minimizing and arranging open 
badge layout windows: cascade, tile horizontally and tile vertically.

Cascade

The cascade option minimizes the windows and arranges them in an overlapping layers starting in the 
top left corner of the screen and moving down and to the right progressively for each window. The 
windows are positioned in this cascade hierarchy according to the last time they were active, with the 
active window (gray rectangle) displaying as the last or topmost window. 

Tile Horizontally

The tile horizontally option minimizes the windows and arranges them side by side in a column, 
starting at the top of the screen with the active window (which remains active). 

Tile Vertically
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The tile vertically option minimizes the windows and arranges them side by side, starting on the left 
side of the screen with the active window (which remains active). 

Note: To automatically minimize and arrange all open badge layout windows choose Cascade 
or Tile Horizontally or Tile Vertically from the Windows menu.

Close All Open Layouts

To close all open BadgeDesigner badge layouts at once:

1. From the Window menu select Close All.

2. If no changes have been made to any of the badge layouts since the last time they were saved to 
the database, the layouts close.

3. If changes have been made to any of the layouts since the last time they were saved to the 
database, a message window displays for each such layout. From each message window, one of 
the following button options must be chosen:

• [Yes] to continue the close function, abandoning the unsaved changes.

• [No] to cancel the close function, so that the layout can be saved.
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CHAPTER 5 Set Layout Properties and View Options
The Layout Properties window is used to customize badge layout specifications. You can also use the 
Layout Properties window to establish default layout properties that will be applied every time a new 
badge is created. 

Layout Form (Page Sub-tab)

The Page sub-tab is used to set page-size and orientation specifications.
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Width
Determines the width (inches or millimeters) of the badge media.

Height
Determines the height (inches or millimeters) of the badge media.

Left margin
Determines where badge(s) are printed in relation to the left edge of the badge media. Enter 
the left “page” margin (inches or millimeters). Badge margin guides display accordingly.

Top margin
Determines where badge(s) are printed in relation to the top edge of the badge media. Enter 
the top margin (inches or millimeters). Badge margin guides display accordingly.

Right margin
Determines where badge(s) are printed in relation to the right edge of the badge media. Enter 
the right “page” margin (inches or millimeters). Badge margin guides display accordingly.

Bottom margin
Determines where badge(s) are printed in relation to the bottom edge of the badge media. 
Enter the bottom margin (inches or millimeters). Badge margin guides display accordingly.

Horizontal resolution
Determines the horizontal DPI of the badge layout as it displays on the screen in 
BadgeDesigner and in print preview. Set the horizontal and vertical resolution to simulate the 
printer resolution. This allows BadgeDesigner and print preview to estimate the amount of 
space that text and barcodes will occupy on the printed page. The actual DPI during printing is 
not affected by this setting. 

MAGICARD printer users should set both the horizontal and vertical resolution layout 
properties to 298 DPI for better accuracy in predicting text and barcode placement on the 
printed page.

Vertical resolution
Determines the vertical DPI of the badge layout as it displays on the screen in BadgeDesigner 
and in print preview. Set the horizontal and vertical resolution to simulate the printer 
resolution. This allows BadgeDesigner and print preview to estimate the amount of space that 
text and barcodes will occupy on the printed page. The actual DPI during printing is not 
affected by this setting.

MAGICARD printer users should set both the horizontal and vertical resolution layout 
properties to 298 DPI for better accuracy in predicting text and barcode placement on the 
printed page.

Orientation
Determines the orientation of the badge which affects how the other information displays. 

Values: Portrait , Landscape 

Rounded (filleted) corners
Used for BadgeDesigner and print preview display purposes only, to show rounded corners of 
badges. If checked, the badge will show rounded (filleted) corners.
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Layout Form (Badge Area Sub-tab)
Horizontal fillet radius
Displays only if the Rounded (filleted) corners check box is selected. Enter the radius 
(inches/millimeters) for the horizontal radius.

Vertical fillet radius
Displays only if the Rounded (filleted) corners check box is selected. Enter the radius 
(inches/millimeters) for the vertical radius.

Paper/PVC color
Used for BadgeDesigner and print preview display purposes only. Displays the color of badge 
media, selected from the Color Palette window. To open the Color Palette window, click the 
[Select] button located to the right of the Paper/PVC Color field.

Default
Sets the values on this form to its pre-defined default values.

Set Default
Saves the current values as default values.

OK
Saves the current values, applies them to the active badge layout(s) and exits the Layout 
Properties window.

Cancel
Exits the Layout Properties window without saving the current settings or changes.

Apply
Applies the current values to the active badge layout(s).

Help
Displays online assistance for this topic.

Notes: When setting the Left, Right, Top and Bottom margin, consider the non-printable area 
specifications of the printer.

For full-bleed printing of the entire page, set the all the margin fields to 0 and set the 
badge width and height to equal the media’s width and height.

Printing over a magnetic stripe will damage your print head.

Layout Form (Badge Area Sub-tab)

The Badge Area sub-tab is used to set the badge options such as size and print spacing.
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Width
Determines the badge width (inches or millimeters). Defines the printable area for each badge 
and the display badge margin guides on the badge layout template.

Height
Determines the badge height (inches or millimeters). Defines the printable area for each badge 
and the display badge margin guides on the badge layout template.

Print preview mode
Choose the way you would like to view the badge in print preview mode.

Multiple badges per page
Enables more than one badge to be printed per badge card/paper if this check box is selected. 
For example, multiple badges can be printed on an 8.5” X 11” piece of paper. This is useful 
when printing out temporary badges. 

Spacing on the page may have to be adjusted to fit the badges depending on the print media 
you are using.

Horizontal spacing
Displays only if the Multiple badges per page check box is selected. Enter the amount of 
blank space you want between each badge and the badge printed to the right of it.

Vertical spacing
Displays only if the Multiple Badges Per Page check box is selected. Enter the amount of 
blank space you want between each badge and the badge printed underneath it.
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Layout Form (Slotted Neck Cord Hole Sub-tab)
Rounded (filleted) corners
Used for BadgeDesigner and print preview display purposes only. Used for BadgeDesigner 
display purposes only, to show rounded corners of badges. If checked, the badge will show 
rounded (filleted) corners.

Horizontal fillet radius
Displays only if the Rounded (filleted) corners check box is selected. Controls the horizontal 
fillet radius.

Vertical fillet radius
Displays only if the Rounded (filleted) corners check box is selected. Controls the vertical 
fillet radius.

Print and fold (2 badge area sections)
Select this option for each badge on the page to be split into two sections.

Fold line orientation
Displays only if the Print and fold (2 badge area sections) check box is selected. Use this to 
select where the fold line will appear on the badge.

Layout Form (Slotted Neck Cord Hole Sub-tab)

The Slotted Neck Cord Hole sub-tab is used to set the placement of the slotted neck cord hole on the 
badge.

The following fields are used only for BadeDesigner and print preview display purposes only.
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A pre-punched slotted neck cord hole exists within the badge area
Selecting this option adds a pre-punched slotted hole onto the badge template.

Hole is partially punched through
Select this option if the hole on your badges is only partially punched through.

Print preview display mode
Select how the hole will be shown during print preview and the layout thumbnails shown in 
the badge layout gallery.

Design-time display mode
Select how the hole will be shown in BadgeDesigner (in all places except the layout gallery).

Badge area section edge
This drop-down box allows you to place the punched hole at the bottom edge, left edge, right 
edge, or top edge of the badge.

Offset from edge
This option allows you to change where the punched hole is placed on the badge.

Slot width
This option allows you to change the slot width of the punched hole.

Slot height
This option allows you to changes the slot height of the punched hole.

Rounded (filleted) corners
Used for BadgeDesigner display purposes only. If checked, the badge will show rounded 
(filleted) corners.

Horizontal fillet radius
Displays only if the Rounded (filleted) corners check box is selected. This option allows you 
to change the horizontal fillet radius of the punched hole.

Vertical fillet radius
Displays only if the Rounded (filleted) corners check box is selected. This option allows you 
to change the vertical fillet radius of the punched hole.

Layout Form (Round Neck Cord Holes Sub-tab)

The Round Neck Cord Holes sub-tab is used to set the placement of the round neck cord holes on the 
badge.
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Layout Form (Round Neck Cord Holes Sub-tab)
The following fields are used only for BadeDesigner and print preview display purposes only.

A pair of pre-punched round neck cord holes exists within the badge area
Selecting this option adds pre-punched round holes onto the badge template.

Holes are partially punched through
Select this option if the holes on your badges are only partially punched through.

Print preview display mode
Select how the hole will be shown during print preview and the layout thumbnails shown in 
the badge layout gallery.

Design-time display mode
Select how the hole will be shown in BadgeDesinger (in all places except the layout gallery).

Badge area section edge
This drop-down box allows you to place the punched holes at the bottom edge, left edge, right 
edge, or top edge of the badge.

Offset from edge
This option allows you to change where the punched holes are placed on the badge.

Hole diameter
This option allows you to change the diameter of the hole on the badge.

Distance between holes
This option allows you to change the distance between the holes on the badge.
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Load Template Form

The Load Template window is displayed by clicking [Load Template] on the Layout folder.

The Load Template window allows you to choose from a number of badge templates to use 
depending on which layout and badge media you are using.

To choose a template: double-click on the template name.

Print Media Templates

Print media templates are available for the following media:

• Avery® 2940 Self-Adhesive Name Badge Labels™ (100 count box)

• Avery® 2941 Self-Adhesive Name Badge Labels™ (500 count box)

• Avery® 2942 Clean Edge Name Badges, Business Card Size™ (100 count box)

• Avery® 2943 Clean Edge Name Badges, Business Card Size™ (500 count box)

• Avery® 2944 Clean Edge Name Badges, Convention Size™ (100 count box)

• Avery® 2945 Clean Edge Name Badges, Convention Size™ (500 count box)

• Avery® 2946 Laminated Name Badges & Self-Adhesive Clips, Business Card Size™ (25 count 
box)

• Avery® 2951 Laminated Name Badges & Self-Adhesive Clips, Business Card Size™ (50 count 
box)

• Avery® 2947 Fold & Clip Name Badges, Landscape, Business Card Size™

• Avery® 2948 Fold & Clip Name Badges, Portrait, Business Card Size™

• Avery® 2949 Fold & Clip Name Badges, Landscape, Convention Size™

• Avery® 2960 Direct Thermal Self-Adhesive Name Badge Labels™ (Roll)

• Avery® 2961 Direct Thermal Fold & Clip Name Badges, Landscape™ (Roll)

• Avery® 2962 Direct Thermal Fold & Clip Name Badges, Portrait™ (Roll)
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Editor Form
• Avery® 2990/2992 Label for Access Control Card - Landscape

• Avery® 2990/2992 Label for Access Control Card - Portrait

• Avery® 2991/2993 Label for Access Control Card - Portrait

• Avery® W5000 Plastic card + Dry peel Clear Media - Landscape

• Avery® W5000 Plastic card + Dry peel Clear Media - Portrait

• Avery® W7100/W9100 Name Badge Media with Hole - Two-Sided - Landscape

• Avery® W9150 Name Badge Media without Hole - Two-Sided - Landscape

• Avery® W9150 Name Badge Media without Hole - Two-Sided - Portrait

• CR-80

• CR-90

• CR-100

Note: Avery and all Avery brands, product names and codes are trademarks of Avery 
Dennison Corporation. Avery product templates are copyrighted, 2004 Avery Dennison 
Corporation. For more information on Avery products, call (800) 462-8379 in the U.S. 
or (888) 462-8379 in Canada, or visit www.avery.com. International Avery contact 
information for localized versions of your Software is available upon request.

Editor Form

To display the Editor form/tab select Layout Properties from the View menu and click the Editor tab. 
This tab is used to set the unit of measure and other general specifications for the badge layout.
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Measurement units
Determines the unit of measure to be used for the badge layout. Values: Inches ("), 
Millimeters (mm)

Grid spacing (Width)
Determines the width (inches or millimeters) between dots on the badge layout.

Grid spacing (Height)
Determines the height (inches or millimeters) between dots on the badge layout.

Snap to grid
Determines whether BadgeDesigner’s automatic snap-to-grid feature is “on” or “off”. Values: 
Checked (Snap to Grid feature is “on”), Not Checked (Snap to Grid feature is “off”)

Show grid
Displays the grid or dots on the badge layout template. Used for display purposes only. Values: 
Checked (dots display), Not Checked (dots do not display)

Zoom
Determines the percentage of zoom used to display the badge layout template in the 
BadgeDesigner window. Values: 25 (%) to 400 (%)

Default
Sets the values on the Editor tab to its previously saved default values.

Set Default
Saves the current values on the Editor tab as default values. 

OK
Saves the current values, applying them to the active badge layout(s) and exits the Layout 
Properties window.

Cancel
Exits the Layout Properties window without saving the current settings or changes.

Apply
Applies the current values to the active badge layout(s).

Help
Displays online assistance for this topic.

Sample Field Data Form

To display the Sample Field Data form/tab select Layout Properties from the View menu and click 
the Sample Field Data tab. This tab is used to change the BadgeDesigner’s default sample data values. 
These data values are used to display badge objects that are linked to BadgeDesigner database fields. 
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Sample Field Data Form
Field
Displays the external field names for each standard cardholder field and custom UDF (user-
defined field) in the BadgeDesigner database that can be linked to a badge object.

Sample Data
Used to edit the sample data values for each BadgeDesigner database field. Highlight the 
sample data value, edit the data as required, then press <Enter>, <Arrow Up> or <Arrow 
Down> to set the value. (The default sample data value for each user-defined field is equal to 
the external field name itself - the descriptive database field name.)

Default
Sets the values on this form to its previously saved default values.

Set Default
Saves the current values as the default values.

OK
Saves the current values, applying them to the active badge layout(s) and exits the Layout 
Properties window.

Cancel
Closes the Layout Properties window without saving the current settings or changes.

Apply
Applies the current values to the active badge layout(s).

Help
Displays online assistance for this topic.

Note: The database fields, "Visit Time In UTC" and "Visit Time Out UTC" will be printed in 
the time zone of the visit. They will not be printed in UTC time, despite the name of the 
field.
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BadgeDesigner View Options

Certain BadgeDesigner behaviors can be configured by individual users. The options users select 
determine what window, if any, displays when an object is added to a badge layout. Users can also 
configure what type of window displays when an object is selected. The default settings for the 
BadgeDesigner view options are shown below.

Action performed upon object insert

Display object properties window
Displays the Object Properties window when an object is inserted in the badge layout. 

Display text window for text/barcode object, gallery window for graphic object
Displays the Text window (for text or barcode objects) or Gallery window (for graphic 
objects) when an object is inserted in the badge layout. 

Do not display any window
Allows you to insert objects without having any property/defining windows appear.

Action performed when double-clicking or pressing <Enter> on selected 
objects

Display object properties window
Displays the Object Properties window when double-clicking or pressing <Enter> on selected 
object(s).

Display text window for text/barcode objects, gallery window for graphic objects
Displays the Text window (for text/barcode objects) or the Gallery window (for graphic 
objects) when double-clicking or pressing enter on selected object(s).

Default
Resets to default settings (which is launch Object Properties window).
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Layout Property Procedures
OK
Saves your changes and exits from the window.

Cancel
Exits this window without saving your changes.

Apply
Saves your changes.

Help
Displays online help for this topic.

Layout Property Procedures

Use the following procedures for Layout Properties.

Open the Layout Properties Window

From the View menu select Layout Properties.

Restore Default Values

To restore the default field values for the current Layout Properties window tab:

1. From the View menu select Layout Properties.

2. Click [Default].

Set New Default Values

To save the field values entered on the current Layout Properties window tab as default settings for 
the badge layout:

1. From the View menu select Layout Properties.

2. Change the appropriate field values.

3. Click [Set Default]. The current field values are saved as default values.

Change Badge Orientation

The Page Orientation Change window allows the user to define what objects will be rotated in turn 
with the page.

1. With a badge layout displayed, select Layout Properties from the View menu.

2. Select Landscape or Portrait from the Orientation drop-down list.

3. Click either [OK] or [Apply].

4. The Page Orientation Change window displays. Select the objects you want rotated along with 
the page. A red checkmark beside the object name indicates the object is selected. Click the 
object name to toggle the checkmark on/off.

Note: Click the Select all objects or Deselect all objects to select or deselect all the objects 
respectively. 
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5. Click [OK].

Save The Layout Property Settings (All Pages)

To save all edited Layout Properties settings to the layout without closing the Layout Properties 
window:

1. From the View menu select Layout Properties.

2. Edit the layout property settings.

3. Click [Apply].

To save all edited Layout Properties settings to the layout and close the Layout Properties window:

1. From the View menu select Layout Properties.

2. Edit the layout property settings.

3. Click [OK].
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CHAPTER 6 Add, Select and Delete Badge Objects
Once a badge layout has been opened and its properties are set, you can start adding objects to the 
layout template.

Objects are added to a badge layout using the Layout view in the BadgeDesigner main window. For 
more information, refer to Layout View on page 28.

Types of Objects

In addition to the standard badge objects (text, photo, barcode, signature, graphic, rectangle, round 
rectangle, circle and ellipse), the software also supports magnetic stripe objects and smart chip 
contacts.

Note: A magnetic stripe object does not permit any other object to overlap it while it displays 
in BadgeDesigner and during printing.

A smart card is a badge ID card that contains a computer chip rather than having a magnetic stripe on 
the back of the card. The smart chip contact can store cardholder data, access control data and 
biometric data, depending on the smart card format.

Object Names

BadgeDesigner automatically assigns an object name to every object added to the badge layout. The 
object name is derived using the object type and a sequential number to uniquely identify each object. 
For example, the first graphic object added to a badge layout is assigned the object name “Graphic”; 
the next graphic object added is assigned the name “Graphic 2”; the next is assigned the name 
“Graphic 3”, etc. Likewise, the first Barcode object added to the layout is assigned the object name 
“Barcode”; the next is assigned the name “Barcode 2”, etc. (An exception is made for text objects: the 
first text object added to a badge layout is assigned the name “Text 1”, not “Text”.)

Object names display in the Object List view in alphabetical order. Once an object has been added to 
the badge layout, it can be renamed by right-clicking the object name, selecting Rename and entering 
the new name. For more information, refer to Rename an Object on page 68.
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Object Sizes

BadgeDesigner also allows you to use a ruler to add an object that is a specific size. While adding an 
object to the badge in Layout view, the ruler displays the size of the object in inches or millimeters. 
Once an object has been added to the badge layout, it can be resized and positioned as necessary. For 
more information, refer to Resize an Object Using the Mouse on page 69.

Object Layer Numbers

Because most objects can be placed on top of one another, BadgeDesigner assigns each object an 
object layer number. When an object is added to a badge layout its object layer number is a sequential 
number that is one greater than the previous object added to the badge layout. For example, the first 
object added to a badge layout is assigned the order layer number “1”; the fifth object added is 
assigned the order number “5”, etc.

BadgeDesigner does not display object layer numbers. These numbers are used only to facilitate 
tabbing through the objects in the badge layout and selecting objects that may be hidden behind other 
objects.

Object layer numbers can be changed by moving objects to different layers in the badge layout. For 
more information, refer to Move an Object To Another Layer on page 68.

Types of Object Property Windows

Different object property windows display depending on the type of object you are working with: 
Text, Cardholder Photo, Barcode, Signature, Graphic, Rectangle, Round Rectangle, Circle and 
Ellipse properties windows. There is also a Magnetic Stripe Properties window and a Smart Chip 
Contacts Property window. 

Each of these windows contain four sections:

• Properties section - upper left corner

• Preview section - upper right corner

• Programmed value section - lower left corner

• Property value section - lower right corner

The Properties section (upper left corner) displays properties appropriate for the type of object you 
are working with. For example some of the properties listed for a Graphic object include Ghost 
Factor, Tile Rows and Fill Color, while some of the properties listed for a Barcode object include 
Barcode Format, Rotation and Fill Color. The example that follows shows the Text Object Properties 
window.

The Property value section (lower right corner) changes according to the property highlighted in the 
Properties section (upper left corner). The values displayed in the Property value section (lower right 
corner) can be changed according to user preference.

In the example that follows, the text property is highlighted in the Properties section (upper left 
corner) and the Property value section (lower right corner) displays a field where you can enter text as 
well as buttons to insert data fields and check digits for barcoding.
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Types of Object Property Windows
Properties 
Displays a list box of object properties and their default values. The object properties listed are 
unique to the type of Object Properties window displayed. For example, the properties listed 
in Text Object Properties window will be different than the properties listed in the Signature 
Object Properties window.

Preview
Displays a magnified preview the objects and its properties. The preview window 
automatically updates to reflect any changes made to the object properties.

Show selected objects only
Displays the selected object in the Preview section, when the check box is selected. If the 
check box is not selected, the object you selected and any other object that overlaps it displays 
in the Preview section.

Programmed value field
Contains the Programmed value display and the Controlling field. These settings are utilized if 
you are using the Program Badge feature. For more information, refer to Program a Badge 
Object on page 111.

Property value field
Located in the lower right portion of the screen. Displays the values that you can assign to an 
object property. Select the object property from the Properties section (upper left corner). The 
Property value field (lower right corner) displays the name of the property (the example above 
displays the Text property values) and the values of that property that you can change. 
Clicking on a different property displays different values.

OK
Applies the current settings to the badge layout and closes the Object Properties window.
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Cancel
Exits the Object Properties window without saving any of the values.

Help
Provides online help for the window.

Object Properties Window Procedures

Use the following procedures in this window.

Display an Object Property Window

1. Open the badge layout.

a. From the Layout menu, select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. You can display the Object Properties window several ways depending on how the 
BadgeDesigner options are set up. Complete any one of the following:

• Select the object you want to edit and click the toolbar button.

Toolbar Shortcut

• Select the object you want to edit and press the <Enter> key.

• Double-click the object you want to edit.

Note: If the Object Properties window does not display, check your view options by selecting 
View > Options.

Select, Deselect or Delete Objects in the Badge Layout

In order to move, rename, resize or delete a badge object, it must be selected. When objects are 
layered over each other, finding and selecting the object you want is not always easy.

Highlighted object

You can verify an object is selected in the Layout view when the selected object displays selection 
handles, eight points surrounding the object. In the Object List view, the name of selected objects is 
also highlighted.

Find an Individual Object

When working with overlapping objects you can quickly find an individual object by taking 
advantage of their object layer number. BadgeDesigner automatically assigns an object layer number 
to every object added to the badge layout. Using the <Tab> key you can select different objects in the 
badge layout.

To find and select individual objects by order layer number:
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1. Open the badge layout.

a. From the Layout menu, select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Choose one of the following:

3. The next object or previous object is selected, based on the object layer number of the most 
recently selected object.

Note: If you know the name of the object you are looking for, it can also be selected via the 
Object List view. Click anywhere in the Object List view and begin typing the name of 
the object you are looking for. The object will automatically be highlighted in both the 
Object List view and the Layout view.

Select One Object

If you do not have overlapping objects you can quickly select a single object:

1. Open the badge layout.

a. From the Layout menu, select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Click the object with the mouse or click and drag the mouse to create a selection box that 
completely encloses the object.

Note: If you know the name of the object you can also select the object by selecting its name 
in the Object List view.

Select a Group of Objects

You can select a group of objects via the Layout view or Object List view.

Select a Group of Objects Using the Layout View

1. Open the badge layout.

a. From the Layout menu, select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

Menu command Shortcut key

Edit > Select Previous <Shift> + <Tab>

Edit > Select Next <Tab>
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2. Hold the <Ctrl> key down while clicking each object to be selected with the mouse, OR click and 
drag the mouse to create a selection box that completely encloses all of the objects.

Select a Group of Objects Using the Object List View

1. Open the badge layout.

a. From the Layout menu, select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Hold the <Ctrl> key down while clicking individual objects or select (highlight) the first object 
in a sequence, hold the <Shift> key down and select (highlight) the last object in a sequence.

Select Every Object

You can select every object via the Layout view or Object List view.

Select Every Object Using the Layout View

1. Open the badge layout.

a. From the Layout menu, select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Choose one of the following:

Select Every Object Using the Object List View

1. Open the badge layout.

2. From the Layout menu, select Open.

3. Select the desired layout from the Open Layout window and click the [OK] button.

4. Select (highlight) the first object in the Object List view.

5. Hold the <Shift> key down and select the last object in listed in the Object List view.

Deselect All Objects

To deselect all objects in the Layout or Object List view, click the mouse anywhere there is an empty 
space in the Layout or Object List view, or choose one of the following:

Delete Objects

To delete an object or group of objects from the badge layout:

1. Select one or more objects to be deleted.

Menu command Shortcut key

Edit > Select All <Ctrl> + <Keypad 5>

Make sure the number lock is off

Menu command Shortcut key

Edit > Deselect All <Shift> + <Esc>
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2. Choose one of the following:

Add Objects to the Badge Layout

A badge layout can contain any combination, size and number of badge objects. When an object is 
added to the badge layout template, it displays in both the Layout view and the Object List view in the 
BadgeDesigner window. For more information, refer to BadgeDesigner Views on page 27.

1. Display the layout view by selecting New or Open from the Layout menu.

• If you selected Open from the Layout menu, select the desired layout from the Open Layout 
window and click the [OK] button.

2. Add an object to the badge layout by selecting the appropriate menu commands or toolbar 
button. Refer to the table below.

Note: Executing the menu commands may automatically display new windows.

Menu command Shortcut key

Edit > Delete <Delete>

Object to be added Menu command Toolbar button

Barcode Edit > Insert > Barcode Object

Cardholder Photo Edit > Insert > Cardholder Photo Object

Cardholder Signature Edit > Insert > Cardholder Signature Object

Circle Edit > Insert > Circle Object

Ellipse Edit > Insert > Ellipse Object

Graphic Edit > Insert > Graphic Object

Magnetic Stripe Edit > Insert > Magnetic Stripe Object

Rectangle Edit > Insert > Rectangle Object

Round Rectangle Edit > Insert > Round Rectangle Object

Smart Chip Contacts Edit > Insert > Smart Chip Contacts

Text Edit > Insert > Text Object
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3. If you used the toolbar button to add an object, move the cursor into Layout view. Notice, the 
cursor changes to cross-hairs. Click and drag the mouse to position the object on the Badge 
layout. Use the status bar display to determine the object size. For more information, refer to 
Status Bar on page 30.

If you used the menu commands to add an object, the object is automatically inserted into the 
upper right corner of the badge layout.

4. Depending on how the BadgeDesigner view options are configured, the Object Property window 
may automatically open. For more information, refer to BadgeDesigner View Options on 
page 52.

If the Object Property window does not automatically open, click the cancel button to close any 
open window, verify the object is selected in the layout view and choose View > Object 
Properties from the menu options. 

5. Make any changes in the Object Properties window by completing the following:

a. Highlight an object property, that you want to change, in the properties section (upper left 
corner of the Object Properties window).

b. The lower right corner of the Object Properties window displays any fields or buttons that 
can be changed or clicked on for that property.

c. Make the appropriate changes and click the [OK] button.

6. The new object displays in the badge layout template (Layout view) and the badge object list 
(Object List view).

Insert Static Text

1. Open a badge layout by completing the following:

a. From the Layout menu, select Open.

b. Select the desired layout and click the [OK] button.

2. Right-click a text object and select Properties. The Object Properties window displays. 

3. Place the cursor in the Property values section’s Text field (lower right corner of the Object 
Properties window) and using the keyboard enter static text.

Insert Graphics

To insert a new graphic or change an existing graphic in the BadgeDesigner layout:

1. Open the badge layout.

a. From the Layout menu, select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Right-click a graphic and choose Select Graphic. The Select Graphic from Database window 
displays. For more information, refer to Select Graphic from Database Window on page 65.

Note: Depending on your view options (View > Options) you can also double-click the 
graphic to display the Select Graphic from Database window.
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3. Select the graphic and click the [OK] button.

Select Graphic from Database Window

Graphic Views area
Displays miniature views of each graphic file in the BadgeDesigner database. Used to link a 
graphic file to selected graphic objects in the badge layout. Also used to select graphic or 
image files to modified, deleted or exported using the [Modify], [Delete] and [Export] buttons. 
To select a graphic or image file, click the appropriate view.

Delete
Deletes or removes the graphic/image files from the BadgeDesigner database.

Rename
Renames a graphic/image file in the BadgeDesigner database.

Modify
Modifies or changes graphic/image files selected in the Graphic Views area. Opens the 
Multimedia Capture for window. For more information, refer to Appendix A: Multimedia 
Capture on page 125.

Import
Imports new graphic files into the BadgeDesigner database by opening the Multimedia 
Capture for window. Once a graphic file is imported using the Multimedia Capture window, it 
displays in the Graphic Views area and can be linked to a graphic object in the badge layout. 
For more information, refer to Import a Supported Image File on page 157.

OK 
Completes the process of linking a graphic from the BadgeDesigner database to the graphic 
object in the badge layout and closes the Select Graphic from Database window.
BadgeDesigner User Guide 65



Add, Select and Delete Badge Objects

66
Cancel 
Cancels or stops the process of linking a graphic or image file to the graphic object and to 
close the Select Graphic from Database window.
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CHAPTER 7 Move, Rename, Resize, and Rotate Badge 
Objects
Any badge object or group of badge objects can be moved to another position within the badge layout 
template. Objects are moved using the Layout view in the BadgeDesigner main window.

Move an Object

1. Open the badge layout.

a. From the Layout menu, select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Select the object(s) to be moved. For more information, refer to Select, Deselect or Delete 
Objects in the Badge Layout on page 60.

3. In the Layout view, position the cursor within the boundaries of one of the selected objects - the 
cursor changes to cross-arrows.

4. Click and hold the mouse to “pick up” the selected objects; drag the mouse to the desired 
location.

5. Release the mouse to complete the move and leave the object(s) in the new location.

“Push” an Object

The keyboard arrow keys can be used to “push” or nudge selected objects up, down, to the left or 
right. The distance an object moves when you nudge it depends on whether the snap-to-grid is on or 
off. 

To “push” or nudge an object or group objects of objects:

1. Open the badge layout.

a. From the Layout menu, select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Select the object to be “pushed”. For more information, refer to Select, Deselect or Delete 
Objects in the Badge Layout on page 60.
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3. Use any combination of the following shortcut keys.

Note: To change the snap-to-grid setting select Layout Properties from the View menu. Click 
the Editor tab and (de)select the Snap to grid check box. 

Move an Object To Another Layer

The object layer number for a selected object can be changed by moving the object in front of or 
behind other objects.

Note: The position of the selected object is not changed when the order layer number changes.

1. Open the badge layout.

a. From the Layout menu, select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Select the object to be moved.

3. Move the object by using the following menu commands or shortcut keys.

Rename an Object

1. Open the badge layout.

a. From the Layout menu, select Open.

Shortcut key Moves object(s)
Distance moved if 
Snap-to-grid is ON

Distance moved if 
Snap-to-grid is OFF

<Up Arrow> up 1 grid unit .001 inches (.01 mm)

<Down Arrow> down 1 grid unit .001 inches (.01 mm)

<Left Arrow> to the left 1 grid unit .001 inches (.01 mm)

<Right Arrow> to the right 1 grid unit .001 inches (.01 mm)

<Ctrl> + <Up Arrow> up 2 grid units .100 inches (1.0 mm)

<Ctrl> + <Down Arrow> down 2 grid units .100 inches (1.0 mm)

<Ctrl> + <Left Arrow> to the left 2 grid units .100 inches (1.0 mm)

<Ctrl> + <Right Arrow> to the right 2 grid units .100 inches (1.0 mm)

Menu command Shortcut key

Edit > Move Forward <Ctrl> + < - >

Edit > Move Back <Ctrl> + < + >

Edit > Move to Front <Alt> + < - >

Edit > Move to Back <Alt> + < + >
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Resize an Object Using the Mouse
b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Select the object.

3. From the Edit menu select Rename Object or right-click the object in the Object List view and 
select Rename. The object name in the Object List view becomes editable.

Note: You can also click the object name in the Object List view twice (not double-click). The 
object name in the Object List view becomes editable.

4. Enter the new name for the object.

Resize an Object Using the Mouse

Objects can be resized using the mouse or the computer keyboard.

1. Open the badge layout.

a. From the Layout menu, select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Select one object to resize.

3. Using the mouse, select one of the selected object’s handles.

Notes: If a side handle is selected, the cursor becomes a horizontal or vertical double-arrow and 
the object can be stretched in either direction indicated by the cursor.

If a corner handle is selected, the cursor becomes a diagonal double-arrow and the 
object can be stretched in either direction indicated by the cursor.

4. Drag the object placeholder and release the mouse when the object is the desired size. The 
BadgeDesigner Status Bar displays the changing size of the object.

Resize an Object Using the Keyboard

Objects can be resized using the mouse or the computer keyboard. When you use the keyboard to 
resize an object the change in object size per keystroke depends on whether the snap-to-grid is on or 
off.

1. Open the badge layout.

a. From the Layout menu, select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Select one object to resize.
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3. Use any combination of the following keyboard keys:

Note: To change the snap-to-grid setting select Layout Properties from the View menu. Click 
the Editor tab and (de)select the Snap to grid check box. 

Rotating Badge Objects

Photo, signature, and graphic objects can be rotated in the object’s properties window. The Rotation 
attribute determines the degree of rotation.

To rotate an object:

Shortcut key
Effect when Snap-to-grid 
OFF Effect when Snap-to-grid ON

<Shift> + <Up Arrow> Reduces height by .001 inches 
(.01 mm)

Reduces height by 1 grid unit

<Shift> + <Up Arrow> Enlarges height by .001 inches 
(.01 mm)

Enlarges height by 1 grid unit

<Shift> + <Up Arrow> Reduces width by .001 inches 
(.01 mm)

Reduces width by 1 grid unit

<Shift> + <Right Arrow> Enlarges width by .001 inches 
(.01 mm)

Enlarges width by 1 grid unit

<Shift> + <Ctrl> + <Up Arrow> Reduces height by .100 inches 
(1.0 mm)

Reduces height by 2 grid units

<Shift> + <Ctrl> + <Down 
Arrow>

Enlarges height by .100 inches 
(1.0 mm)

Enlarges height by 2 grid units

<Shift> + <Ctrl> + <Left 
Arrow>

Reduces width by .100 inches 
(1.0 mm)

Reduces width by 2 grid units

<Shift> + <Ctrl> + <Right 
Arrow>

Enlarges width by .100 inches 
(1.0 mm)

Enlarges width by 2 grid units
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Rotating Badge Objects
1. Double-click the object you want to rotate.

2. Choose the rotation property in the object’s Properties window.

3. Change the degree of rotation in the rotation drop-down box in the Rotation section of the screen.

4. Click [OK].
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CHAPTER 8 Set General Formatting Attributes
The General Formatting toolbar contains buttons to set the fill style, fill color, border style, border 
color and border width as well as text justification, background transparency and scale-to-fit, 
attributes for most objects. It also contains a button to open the Text window and set database fields 
for text objects and insert check digits for barcode objects.

Set Fill and Border Attributes

The following table provides General Formatting toolbar shortcuts and instructions.

Set Fill Style

This determines the fill pattern of any object.

1. Open a badge layout and select an object or group of objects.

a. From the Layout menu select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Click the Set Fill Style toolbar button and select a fill style from drop-down list that displays.

Toolbar button
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Fill Options

Notes: You must select a fill style or press <Esc> to close the drop-down list.

For barcode objects, use the solid fill style to create a security block.

Set Fill Color

This determines the fill style color of any object. 

1. Open a badge layout and select an object or group of objects.

a. From the Layout menu select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Click the Set Fill Color toolbar button. 

3. The Color window opens. Select a color or define a custom color, then click the [OK] button.

Notes: If the fill color you selected is not applied, verify that the Set Fill Style is set to 
something other than None.

For barcode objects, use a red fill color to create a security block.

Set Border Style

This determines the line style for the border or frame of any object.

1. Open a badge layout and select an object or group of objects.

a. From the Layout menu select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Click the Set Border Style toolbar button  and select a border style from drop-down list that 
displays.

Border options
BadgeDesigner User Guide



Set Fill and Border Attributes
Note: You must select a border style or press <Esc> to close the drop-down list.

Set Border Color

This determines the color of the border of any object.

1. Open a badge layout and select an object or group of objects.

a. From the Layout menu select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Click the Set Border Color toolbar button. 

3. The Color Palette window opens. Select a color or define a custom color, then click the [OK] 
button.

Note: If the border color you selected is not applied, verify that the Set Border Style is set to 
something other than None. 

Set Border Width

This determines the width of the line used for the border of an object.

1. Open a badge layout and select an object or group of objects.

a. From the Layout menu select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Click the Set Border Width toolbar button. 

3. The Border Width dialog box opens. Enter a Border Width, then click the [Close] button.

Border width options

Note: If the border width is set to 0.0, the default line width (usually 1 pixel) is applied.

Create Custom Colors

Custom colors can be defined in BadgeDesigner through use of a standard Windows color selection 
dialog. Each badge layout can store up to 16 custom colors. 

To create a new custom color:

1. Open the badge layout.

a. From the Layout menu select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Select an object or group of objects in the badge layout.

3. Click the Set Fill Color  toolbar button. 

4. Click the [Define Custom Colors] button in the Color dialog window.

5. The window expands to show the following:
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6. Use your mouse to select the color you want or if you know the exact color settings, enter them in 
the appropriate fields (Hue, Saturation, Luminosity or Red, Green and Blue).

7. Click the [Add to Custom Colors] button. The color is added to the Custom colors display.

8. Click the [OK] button to save and exit from the window. 

Set Horizontal Justification

The horizontal justification attribute can be set for every photo, signature, graphic and text object. 
This attribute determines the horizontal placement of an object within its frame or placeholder.

1. Open the badge layout.

a. From the Layout menu select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Select the object.

3. Refer to the table below for the appropriate toolbar button to select. 

Set Vertical Justification

The vertical justification attribute can be set for every photo, signature, graphic and text object. This 
attribute determines the vertical placement of an object within its frame or placeholder.

1. Open the badge layout.

a. From the Layout menu select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Select the object.

Toolbar button Description

 Left Justify
Sets Horizontal Justification attribute to “Left”.

 Center Horizontally
Sets Horizontal Justification attribute to “Center”.

 Right Justify
Sets Horizontal Justification attribute to “Right”.
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3. Refer to the table below for the appropriate toolbar button to select.

Set Background Transparency Attributes

The Toggle Background Transparency  toolbar button can be used with every text, photo, bit 
map signature and graphic object. The Toggle Background Transparency toolbar button automatically 
toggles the fill style attribute for objects between “none” and “solid”.

Background transparency on vs. background transparency off:

There are three requirements for background transparency to be activated for text, photos, bit map 
signatures and graphics:

• The workstation must be licensed for chromakey (via the dongle).

• The background transparency attribute must be turned on for that object via the toolbar button.

• Chromakey must be performed on the object via the Multimedia Capture Window. For more 
information, refer to Chromakey Sub-tab on page 130.

If one of these requirements is not met, the object will be printed/displayed with an opaque 
background.

1. Open the badge layout.

a. From the Layout menu select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Select the object.

3. Click the Toggle Background Transparency toolbar button.

Toolbar button Description

 Top Justify
Sets Vertical Justification attribute to “Top”.

 Center Vertically
Sets Vertical Justification attribute to “Center”.

 Bottom Justify
Sets Vertical Justification attribute to “Bottom”.
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Set Scale-To-Fit Attributes

The Toggle Scale-Down-to-Fit  toolbar button determines whether the font size for the text 
object should be automatically scaled down so the entire text line fits within its placeholder. The 
scale-to-fit attribute only applies to text objects. 

Scale-to-fit off vs. scale-to-fit on:

1. Open the badge layout.

a. From the Layout menu select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Select a text object.

3. Click the Toggle Scale-Down-to-Fit toolbar button.
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CHAPTER 9 Set Graphic, Photo and Signature 
Attributes
The Graphic toolbar contains buttons to set the ghosting, aspect ratio and tiling attributes for photo, 
signature and graphic objects. It also contains buttons to set the pen width and pen color for signature 
objects. These attributes can also be defined using the Object Properties window.

Set Ghosting Attributes

The ghosting attribute determines the level of transparency of a selected object. It can be applied to 
photos, graphics or bit map signatures.

In order to use ghosting:

• The workstation must be licensed for ghosting (via the dongle).

• The object’s ghosting factor must be greater than 0.

• The current OnGuard user must have the Ghosting Print Badges Cardholder Level Permission.

Ghosting off vs. ghosting on

To adjust the ghosting factor

1. Click the Adjust Ghost Factor  toolbar button. The Ghost Factor dialog box opens.
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2. Enter a ghost factor between 0 and 255. The higher the number, the greater the ghost factor.

3. Click the [Close] button.

Set Aspect Ratio Attributes

The aspect ratio is the ratio of the graphic object’s width to its height. There are three different modes 
to choose from when working with aspect ratios:

• Do not preserve aspect ratio. If this option is used, a graphic object’s width in relation to its 
height is not maintained when the graphic object is resized.

• Preserve aspect ratio without cropping. If this option is used, a graphic object’s width in 
relation to its height is maintained when the graphic object is resized, but blank spaces are used 
around the image within the bounding rectangle if needed.

• Preserve aspect ratio with cropping. If this option is used, a graphic object’s width in relation 
to its height is maintained when the graphic object is resized, but the image is cropped if 
necessary in order to use all available space within the bounding rectangle.

To select an aspect ratio mode, select a graphic object and then choose an appropriate aspect ratio 
mode icon on the Graphic Formatting toolbar. The table that follows summarizes the aspect ratio 
modes.

Set Tiling Attributes

The tiling attribute is used to create a tiled pattern using repeated, reduced-size versions of the 
graphic. The tiled pattern can include a fixed number of rows and/or columns. It can also be set to 
automatically determine the number of rows and/or columns, based on what will fit within the object 
frame.

Aspect ratio modes

Aspect ratio 
mode

Graphic 
Formatting 
toolbar 
icon Description Illustration

Do not preserve 
aspect ratio

Object’s width in relation to its height is 
not maintained when the graphic object 
is resized

Preserve aspect 
ratio without 
cropping

Object’s width in relation to its height is 
maintained when the graphic object is 
resized, but blank spaces are used 
around the image within the bounding 
rectangle if needed

Preserve aspect 
ratio with 
cropping

Object’s width in relation to its height is 
maintained when the graphic object is 
resized, but the image is cropped if 
necessary in order to use all available 
space within the bounding rectangle
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Set Signature Pen Width and Color
Tiling off vs. tiling on

Tiling off

Tiling on

To set tiling attributes:

1. Open the badge layout.

a. From the Layout menu select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Select the graphic, photo or signature to be tiled. Click the Set Tiling Parameters  toolbar 
button.

3. The tiling dialog box opens. Choose a tiling option and set the number of tiles to be used then, 
click the [Close] button.

Set Signature Pen Width and Color

To set signature pen width and color attributes for selected signature objects, use the Graphic toolbar 
buttons and instructions described in the following table.
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Set Signature Pen Width

This determines the width of the line to be used to print the signature itself. If set to 0.0, the default 
line width for the badge printer (usually 1 pixel) will be used.

1. Open a badge layout and click the Set Signature Pen Width toolbar button. 

2. The Signature Pen Width dialog box opens. Enter a Signature Pen Width, in inches or 
millimeters, then choose the [Close] button. 

Border width dialog box

Set Signature Pen Color

This is used to set the color to be used to print the signature itself.

1. Open a badge layout and click the Set Signature Pen Color toolbar button. 

2. The Color Palette window opens. Select a color, then choose the [OK] button.

Note: This button is disabled when the Use Original Pen Color attribute is on.

Toggle Original Pen Color Use

This toggles (on/off) the Use Original Pen Color attribute.

If this attribute is on, the signature pen color will be automatically set to the color used when the 
signature image was captured and the Set Signature Pen Color tool button is disabled.

Set Horizontal and Vertical Fillet Radius

The horizontal and vertical fillet radius is used set rounded corners on the smart chip contact, rounded 
rectangle, photo, signature, and graphic objects. Refer to the examples below of a rounded-rectangle 
with a high value for the horizontal fillet radius and a high value for the vertical fillet radius 
(respectively).
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CHAPTER 10 Set Text Attributes
Options to format text are available on both the Text Formatting toolbar and on the General 
Formatting toolbar. This section describes the options available on the Text Formatting toolbar; for 
information about the text-related General Formatting toolbar options, refer to Chapter 11: Insert 
Fields into Text Objects on page 89..

Text Formatting Toolbar Procedures

The Text Formatting toolbar contains buttons for setting font and font size, font style, upper or lower 
case, text color and word wrap attributes for selected text objects. It also contains a box in which the 
maximum number of characters for selected text objects can be set.

Note: Badges that will be printed in Visitor Management should be designed using TrueType 
fonts.

Set Font and Font Size

To set font and font size attributes for selected text objects:

1. Open the badge layout by completing the following:

a. From the Layout menu select Open.

b. Select the desired layout from the Open Layout window.

c. Click the [OK] button.

2. Set the font and font size attributes by either:

• Selecting the text object and entering the font and font size using the following sections of 
the toolbar:
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• Double-clicking the text object and setting the font and font size attributes using the Object 
Properties window (refer to the steps below).

i. Highlight the Font property in the properties listbox (upper left corner of the Object 
Properties window).

ii. In the lower right corner of the Object Properties window enter the font and font size for 
the selected text object.

iii. Click the [OK] button.

Set Font Style

The font style attribute determines whether the selected objects will be printed using bold, italic and/
or underlining font styles. 

Set Display Case

The display case attribute determines whether a case display mask should be used to print the selected 
text objects. There are two case display masks that can be used: Upper Case, Lower Case. A mixed 
display case occurs when both the upper and lower case attributes are toggled off. Refer to the 
examples below:

Set Text Color

The text color attribute determines the foreground color for selected text objects - the color in which 
the actual text is printed. 

To set the text color for selected text objects:

Toolbar button Description 

 

Toggles (on/off) the bold attribute for selected text objects.

 

Toggles (on/off) the italics attribute for selected text 
objects.

 

Toggles (on/off) the underlined attribute for selected text 
objects.

Toolbar 
button Description Example

Toggles the upper case attribute on/off. 
When this attribute is on, the selected text 
objects are displayed in all uppercase.

SAMPLE TEXT

Toggles the lower case attribute on/off. 
When this attribute is on, the selected text 
objects are displayed in all lowercase.

sample text

Toggles the both upper and lower case 
attributes off. 

Sample Text
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Text Formatting Toolbar Procedures
1. Open the badge layout.

a. From the Layout menu select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Set the text color attribute by either:

• Selecting the text object and clicking the Set Text Color  toolbar button.

• Double-clicking the text object and setting the text color attribute using the Object 
Properties window (refer to the steps below). 

i. Highlight the Text Foreground Color property in the properties listbox (upper left 
corner of the Object Properties window).

ii. In the lower right corner of the Object Properties window click the [Select] button. 

3. The Color window opens, select the desired color or define a custom color.

4. Click the [OK] button.

Set Word Wrap

The word wrap attribute determines whether the text value for each selected text object is 
automatically “wrapped” to fit within the object frame.

To set the word wrap attribute for selected text objects:

1. Open the badge layout.

a. From the Layout menu select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Set the word wrap attribute by either:

• Selecting the text object and toggling the word wrap attribute on/off using the Toggle Word-

Wrap  toolbar button.

• Double-clicking the text object and setting the word wrap attribute using the Object 
Properties window (refer to the steps below). 

i. Highlight the Word Wrap property in the properties listbox (upper left corner of the 
Object Properties window).

ii. In the lower right corner of the Object Properties window select the Word Wrap check 
box to turn word wrap on or deselect the check box to turn it off.

iii. Click the [OK] button.

Note: Word wrap must be turned on in order for the object text to show up as multiple lines. 

Set the Maximum Characters Displayed

The maximum characters attribute determines the maximum number of characters displayed and 
printed per text object.

To set the maximum characters for selected text objects:

1. Open the badge layout.

a. From the Layout menu select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Set the maximum character attribute by either:
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• Selecting the text object and entering the maximum characters, to display and print, using 
the following toolbar location:

• Double-clicking the text object and setting the maximum characters, to display and print, 
using the Object Properties window (refer to the steps below). 

i. Highlight the Max Text Chars property in the properties listbox (upper left corner of 
the Object Properties window).

ii. In the lower right corner of the Object Properties window enter the maximum characters 
to be displayed and printed for the selected text object.

iii. Click the [OK] button.
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CHAPTER 11 Insert Fields into Text Objects
Text can be formatted using the options on the Text Formatting toolbar. For more information, refer to 
Chapter 10: Set Text Attributes on page 85.. Text objects can also have a custom layout created that 
includes fields, which is the focus of this section.

Text-related General Formatting Toolbar Options

The Set Text and Database Fields  and Object Properties  functions are on the General 
Formatting toolbar. Their functionality as it applies to text fields is discussed in this section.

When a text object is selected, clicking the Set Text and Database Fields  toolbar button opens 
the Text window. For more information on the Text Properties window, refer to Types of Object 
Property Windows on page 58. Likewise, when a text object is selected, clicking the Object 

Properties  opens the Text Properties window. For more information on the Text window, refer 
to Text Window on page 90. 

In either of these windows, you may insert or append fields to link to the text field. There are three 
types of fields that can be inserted into a custom layout: ASCII codes, check digits, and database 
fields.

• ASCII code: Non-printable characters. Opens the ASCII Code Field Properties dialog from 
which non-printable characters can be selected.

• Check Digit: Check digits are special digits used by barcode/magnetic readers to verify that a 
series of data digits have been properly encoded. A check digit would only be inserted into a 
barcode field. Opens the Check Digit Field Properties dialog in which different algorithms can be 
selected.

• Database Field: Opens the Database Field Properties window in which you can select different 
Field values and insert database links.
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Text Window

The Text window is used with text and barcode objects. It is displayed by clicking Set Text and 

Database Fields  on the General Formatting toolbar. Through the Text window you can insert 
database fields into text objects and insert check digits into barcode objects. Check digits are special 
digits used by barcode/magnetic readers to verify that a series of data digits have been properly 
encoded.

Sample output
Displays a sample output of the data. This display only field automatically updates whenever 
changes are made to the Text window.

Text
Displays the text values of an object. Text values consist of a combination of static text, 
database links to specific BadgeDesigner database fields and non-printable characters. This 
field may contain static text, check digits (shown inside double-caret brackets and curly 
brackets: <<{XXX}>>), or database fields (shown inside double-caret brackets: <<field 
name>>). Select the field and then click [Field Properties] to display information about the 
field. Enter values in this field using the following methods:

• Use the keyboard to enter static text values.

• Use the [Insert Field] button to display the Select Field Type dialog and add a field 
wherever the cursor is currently positioned in this field. 

• Use the [Append Field] to display the Select Field Type dialog and add a field at the end of 
all values listed in this field. 

Field Properties
Enabled only when a field’s text value is selected in the Text field. Displays the field 
properties window for the selected field (Database Field Properties, ASCII Code Field 
Properties, or Check Digit Field Properties, depending on the field type).

Insert Field
Opens the Select Field dialog, which is used to insert ASCII code, check digits, or database 
fields into the text values wherever the cursor is in the Text field.

Append Field
Opens the Select Field dialog, which is used to append or add ASCII code, check digits, or 
database fields to the end of all text values listed in the Text field.
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Select Field Type Dialog
OK
Saves the settings and closes the Text window. 

Cancel
Closes the Text window without saving or applying the settings.

Apply
Applies the settings to the selected object (does not close the Text window).

Help
Used to open a context-sensitive Help topic window.

Select Field Type Dialog

The Select Field Type dialog is used to insert ASCII code, check digit, or database fields into a text 
field in a badge layout.

To display the Select Field Type dialog, click [Insert Field] or [Append Field] on the Text or Text 
Properties window.

Field Type
Types of fields that can be inserted into a field in a badge layout include:

• ASCII code: Non-printable characters. Opens the ASCII Code Field Properties dialog 
from which non-printable characters can be selected.

• Check Digit: Check digits are special digits used by barcode/magnetic readers to verify 
that a series of data digits have been properly encoded. A check digit would only be 
inserted into a barcode field. Opens the Check Digit Field Properties dialog in which 
different algorithms can be selected.

• Database Field: Opens the Database Field Properties window in which you can select 
different Field values and insert database links.

OK
Saves the changes you have made and exits the window.

Cancel
Exits the window without saving the changes.

Help
Displays online help for this topic.
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ASCII Code Field Properties Dialog

The ASCII Code Field Properties dialog is used to insert non-printable characters into a text field.

To display the Select Field Type dialog, click [Insert Field] or [Append Field] on the Text or Text 
Properties window, and then select “ASCII Code”.

Code value
Displays the ASCII code value for the non-printable character to insert into the text field. To 
select a new code value, click [Select from ASCII Table].

Select from ASCII Table
Displays the Select Decimal ASCII Code dialog. Select the code you wish to insert into the 
field, and then click [OK]. The Select Decimal ASCII Code dialog closes, and the value will 
be displayed in the Code value field. Click [OK] to add it to the field.

OK
Saves the changes you have made and exits the window.

Cancel
Exits the window without saving the changes.

Help
Displays online help for this topic.

Select Decimal ASCII Code Dialog

The Select Decimal ASCII Code dialog lists all ASCII codes in decimal and hexadecimal, as well as 
the code name for each.

The Select Decimal ASCII Code dialog is displayed by clicking the [Select from ASCII Table] button 
on the ASCII Code Field Properties window. It is also displayed by clicking the [Select from ASCII 
Table] button on the Database Field Properties window (Text/numeric).
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Check Digit Field Properties Dialog
Code in Decimal
Lists the code for the decimal (base-ten) representation of the character(s).

Code in Hexadecimal
Lists the code for the hexadecimal (base-sixteen) representation of the character(s).

Code Name
Lists the international standard character name.

OK
Once you have selected an ASCII code, click this button to save the changes and exit from this 
window.

Cancel
Exits the window without saving the changes.

Help
Displays online help for this topic.

Check Digit Field Properties Dialog

The Check Digit Field Properties dialog is used to insert non-printable characters into a barcode field.

Algorithm
Lists the check digit types that are available. OnGuard currently supports the following five 
types:
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• ISO7812-1: A check digit of this type immediately follows the associated data and is 
calculated from all previous digits since the last check digit. It is the same kind of check 
digit used for data encoded on the magnetic strips of credit cards and is calculated via the 
Luhn Formula described in the International Standards Organization document ISO/IEC 
7812-1:1993.

• Left-to-Right CK01: A check digit of this type immediately follows the associated data 
and is calculated from all previous digits since the last check digit. It is used for barcodes 
and is calculated via a modulus 10 based algorithm created by a barcode products company 
called DATA2.

• Right-to-Left CK01: A check digit of this type immediately precedes the associated data 
and is calculated from all the digits following the check digit, up to the digit that precedes 
the next check digit. It is used for barcodes and is calculated via a modulus 10 based 
algorithm created by a barcode products company called DATA2.

• Modulo 43: The Modulo 43 check character type is the native (symbology level) check 
character for the Code 3 of 9 barcode symbology. It is the check character type used for 
HIBC barcode data when using either the Code 128 or the Code 3 of 9 symbology. This is 
commonly used by the health care industry.

• Modulo 43 Extended: The Modulo 43 Extended check character type is the native 
(symbology level) check character for the Extended Code 3 of 9 barcode symbology (also 
known as Code 3 of 9 Full ASCII or Extended Code 39 or Code 39 Full ASCII barcode 
symbology). This check character type is identical to the Modulo 43 check character type 
except that it supports all 128 characters in the standard ASCII character set. This check 
character type is NOT used for HIBC barcodes. This is commonly used by the health care 
industry.

OK
Saves the changes you have made and exits the window.

Cancel
Exits the window without saving the changes.

Help
Displays online help for this topic.

Database Field Properties Window (Blank)

The Database Field Properties window (Blank) is used to format the fields you inserted into a text 
object using the Text window or the Text Properties window. The contents of this window changes 
depending on whether the type of field selected in the Field drop-down is blank, text/numeric, or 
date/time.

The Database Field Properties window (Blank) displays when you click the [Insert Field] button in 
the Text or Text Properties window and then select “Database Field” in the Select Field Type dialog.
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Field
Displays a list of the BadgeDesigner database fields that can be linked to the object (including 
standard BadgeDesigner database fields and user-defined database fields). The contents of the 
Database Field Properties window changes depending on whether the field selected in this 
drop-down is blank, text/numeric, or date/time.

OK
Saves the changes you have made and exits the window.

Cancel
Exits the window without saving the changes.

Help
Displays online help for this topic.

Database Field Properties Window (Date/time)

The Database Field Properties window (Date/time) is used to format the date/time database fields you 
inserted into a text object using the Text window or the Text Properties window. The contents of this 
window depend on whether the type of value in the Field drop-down is blank, text/numeric, or date/
time.

Note: In BadgeDesigner, you may select a Field; in System Administration and ID 
CredentialCenter, the Field is always grayed out.
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The Database Field Properties window (Date/time) displays when you click the [Insert Field] button 
in the Text or Text Properties window, select “Database Field” in the Select Field Type dialog, and 
then select a date/time field in the Field drop-down in the Database Field Properties window.

Field
Describes the object being modified. The contents of the Database Field Properties window 
changes depending on whether the field selected in this drop-down is blank, text/numeric, or 
date/time.

In BadgeDesigner, you may select a Field; in System Administration and ID CredentialCenter, 
the Field is always grayed out.

Sample output
Displays a sample output of the data. This field is display-only, and is automatically updated 
as changes are made. 

Use FormsDesigner formatting
Check this box to use the field formatting as shown in the Cardholders form. For example, the 
activate date could appear as “1/1/2001” instead of “Monday, January 01, 2001 12:00 AM.” 
Newly inserted field references default to having this option checked.

Date/time format
Enabled for selection if the Use FormsDesigner formatting check box is deselected. Allows 
you to choose from a predefined list how the field will be formatted.

Custom format
Enabled for selection if you select Custom from the Date/time format drop-down list. 
Allows you to design a customized format using the formatting codes.
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Database Field Properties Window (Text/numeric)
Custom formatting codes
Enabled for selection if you select Custom from the Date/time format drop-down list. 
Provides a predefined list of formatting codes you can use to customize the field format.

Insert formatting code
Enabled only when an entry is selected in the Custom formatting codes list. Click this button 
to apply a selected custom formatting code to an output. The Sample output field will then be 
updated with a preview of the output.

OK
Saves the changes you have made and exits the window.

Cancel
Exits the window without saving the changes.

Help
Displays online help for this topic.

Database Field Properties Window (Text/numeric)

The Database Field Properties window (Text/numeric) is used to format the text/numeric database 
fields you inserted into a text object using the Text window or the Text Properties window. The 
contents of this window depend on whether the type of value in the Field drop-down is blank, text/
numeric, or date/time.

Note: In BadgeDesigner, you may select a Field; in System Administration and ID 
CredentialCenter, the Field is always grayed out.

The Database Field Properties window (Text/numeric) displays when you click the [Insert Field] 
button in the Text or Text Properties window, select “Database Field” in the Select Field Type dialog, 
and then select a text/numeric field in the Field drop-down in the Database Field Properties window.
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Field
Describes the object being modified. The contents of the Database Field Properties window 
changes depending on whether the field selected in this drop-down is blank, text/numeric, or 
date/time. 

In BadgeDesigner, you may select a Field; in System Administration and ID CredentialCenter, 
the Field is always grayed out.

Sample output
Displays a sample output of the data. This field is display-only, and is automatically updated 
as changes are made. 

Use FormsDesigner formatting
Check this box to use the field formatting as shown on the Cardholder screen. For example, 
the phone number could appear as “(123) 456-7890” instead of “1234567890.” The field 
defaults to having this option checked.

Fixed length
Check this box if the field data should contain a specific number of characters/numbers.

Number of characters
Specify the number of characters or numbers in this field.

Pad on
Pads or truncates fields on the left or the right. When the Fixed length check box is selected, 
field data will be truncated on the left/right if the cardholder’s data for that field exceeds the 
specified number of characters. If the cardholder’s data for that field is less than the specified 
number of characters the field data will be padded on the left/right.
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ASCII code value
Using ASCII Code, choose the pad character. If the data is padded on the left, the pad 
character(s) will show up before the data. If the data is padded on the right, the pad 
character(s) will show up after the data. 

Select from ASCII Table
Brings up the Select Decimal ASCII Code dialog and allows you to select the pad character 
from a list.

OK
Saves the changes you have made and exits the window.

Cancel
Exits the window without saving the changes.

Help
Displays online help for this topic.

Link Database Fields to Text

Using the Text window or Text Properties window you can link database fields such as cardholder 
name, building and department to text. Depending on the field type, you can also elect to use 
FormsDesigner formatting and set a fixed length for the database field.

1. Open the badge layout by completing the following:

a. From the Layout menu select Open.

b. Select the desired layout and click the [OK] button.

2. Right-click a text object and select Properties (or click the Object Properties  toolbar 
button). The Text Properties window displays. Alternately, click the Set Text and Database Fields 

 toolbar button. The Text window displays. 

3. On either the Text Properties window or the Text window, click [Insert Field]. The Select Field 
Type dialog opens.

4. In the Select Field Type dialog, select the type of field to insert. Choices include ASCII code, 
check digits, or database field.

• For more information on ASCII codes, refer to Insert an ASCII Code on page 99.

• For more information on check digits, refer to Insert a Check Digit on page 104.

• For more information on database fields, refer to Insert a Database Field on page 100

5. The Sample output field is updated to reflect the fields listed in the Text field. Once this is 
satisfactory, click [OK].

Insert an ASCII Code

1. In the Select Field Type dialog, select “ASCII Code”.

2. Click [OK].

3. The ASCII Code Field Properties window opens. Click [Select from ASCII Table].
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4. The Select Decimal ASCII Code window opens. Select the desired code, and then click [OK].

5. On the ASCII Code Field Properties window, click [OK]. The code is added to the Text field.

Insert a Database Field

1. In the Select Field Type dialog, select “Database Field” and then click [OK].

2. The Database Field Properties window opens. In the Field drop-down, select the desired field.

3. The fields on the Database Field Properties window change depending on whether the selected 
Field is text/numeric or date/time. 

• If a date/time field is selected: 

1) Select or deselect the Use FormsDesigner formatting check box.

2) If you deselected the Use FormsDesigner formatting check box, select the Date/time 
format from the drop-down list. 

If you select Custom from the drop-down list, highlight the Custom formatting codes 
you want to apply (located at the bottom of the screen) and click the [Insert Selected 
Code into Custom Format] button.

Click [OK]. 

• If a text/numeric field is selected:

1) Select the Use FormsDesigner Formatting check box if you want to use the field 
formatting as shown on the Cardholder screen.

2) Select the Fixed length check box if you want the database field to have a fixed length. 
Enter the number of characters you want the fixed length to be. Using the Pad on drop-
down list, select whether extra digits will be truncated/add on the left or right. Select the 
pad character.

3) Click [OK].
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CHAPTER 12 Set Barcode Attributes
The barcode toolbar contains buttons set the barcode rotation and format. Although there is not a 
toolbar button to insert a check digit, this aspect of working with barcodes is also discussed in this 
section. 

Set Barcode Format

The barcode format attribute determines the actual code scheme used to create barcodes. The 
attributes can be defined through the Object Properties window or the Set Barcode Type toolbar 
button.

1. Open the badge layout.

a. From the Layout menu select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Set the barcode format by either:

• Selecting the barcode object and setting the barcode type using the following toolbar button:

• Double-clicking the barcode object and setting the barcode format using the Object 
Properties window (refer to the steps below).

i. Highlight the Barcode Format property in the properties listbox (upper left corner of 
the Object Properties window).

ii. In the lower right corner of the Object Properties window select the desired barcode 
type and click the [OK] button.
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The following are barcode formats available in BadgeDesigner. 

Barcode Formats Table

Barcode type or 
format Valid data characters Check digit

Aztec Code All 8-bit values can be encoded. Values 0 - 127 are 
interpreted as the ASCII character set while values 128 - 
255 are interpreted as ISO 8859-1, Latin Alphabet No. 1.

Two non-data characters can be encoded, FNC1 for 
compatibility with some existing applications and ECI 
escape sequences for the standardized encoding of 
message interpretation information. 

Yes

Codabar 0 1 2 3 4 5 6 7 8 9 A B C D - $ : / . + No

Code 128 Auto full ASCII character set Yes

Code 128-A space ! " # $ % & ‘ ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? 
@ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 
[ \ ] ^ _

(Control code characters currently not supported, see 
notes below.)

Yes

Code 128-B space ! " # $ % & ‘ ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? 
@ A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 
[ \ ] ^ _ a b c d e f g h i j k l m n o p q r s t u v w x y z { | } ~ 

(Control code characters currently not supported, see 
notes below.)

Yes

Code 128-C 0 1 2 3 4 5 6 7 8 9

(Control code characters currently not supported, see 
notes below.)

Yes

Code 3 of 9 2:1

(2:1 narrow-to-wide 
bar width ratio)

0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S 
T U V W X Y Z - . * $ / + %

No

Code 3 of 9 3:1 
(ANSI)

(3:1 narrow-to-wide 
bar width ratio)

0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S 
T U V W X Y Z - . * $ / + %

No

Code 93 0 1 2 3 4 5 6 7 8 9 A B C D E F G H I J K L M N O P Q R S 
T U V W X Y Z - . * $ / + %

Yes

EAN-13 0 1 2 3 4 5 6 7 8 9

For EAN-13 exactly 12 digits must be specified. This is a 
fixed length symbology

Yes

EAN-8 0 1 2 3 4 5 6 7 8 9

Exactly 7 digits must be specified. This is a fixed length 
symbology.

Yes

Extended Code 3 of 
9

full ASCII character set No
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Notes: Code 128 Auto automatically selects back and forth between Code 128-A, Code 128-B 
and Code 128-C within the same barcode to produce the smallest barcode (fewest 
number of bars). The switching is driven by minimum length calculations and the 
characters being printed.

OnGuard currently doesn’t allow control codes to be specified in the Text property for 
barcode objects. Some of these codes would allow users to force the bar patterns to 
switch amongst Code 128-A, Code 128-B and Code 128-C midstream within the same 
barcode. Users who want the symbology to switch between these three symbologies 
within a single barcode must use Code 128 Auto.

Set Barcode Rotation

The barcode rotation attribute determines the degree of rotation to be used to print the barcode.

1. Open the badge layout.

a. From the Layout menu select Open.

b. Select the desired layout from the Open Layout window and click the [OK] button.

2. Set the barcode rotation by either:

• Selecting the barcode object and setting the barcode type using the toolbar button.

• Using the Object Properties window (refer to the steps below).

i. Right-clicking the barcode object and selecting Properties.

ii. Highlight the Rotation property in the properties listbox (upper left corner of the Object 
Properties window).

Extended Code 93 full ASCII character set Yes

Interleaved 2 of 5 
3:1

0 1 2 3 4 5 6 7 8 9 No

PDF417 full ASCII character set

Note: The PDF417 symbology is a two-dimensional, 
character self-checking, bi-directionally 
decodable symbology allowing up to almost 3 KB 
of data depending on the types of characters 
within the data. 

No

POSTNET 0 1 2 3 4 5 6 7 8 9 Yes

UCC-128
(also known as 
EAN-128)

0 1 2 3 4 5 6 7 8 9
Exactly 11 digits must be specified. This is a fixed length 
symbology.

Yes

UPCA
(also known as 
UPC-A)

0 1 2 3 4 5 6 7 8 9
Exactly 11 digits must be specified. This is a fixed length 
symbology.

Yes

Barcode Formats Table

Barcode type or 
format Valid data characters Check digit
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iii. In the lower right corner of the Object Properties window enter the degree of rotation 
and click the [OK] button.

Insert a Check Digit

A check digit is also known as a checksum character and is the number located on the far side of a 
barcode. The purpose of a check digit is to verify the barcode (a series of data digits) have been 
properly encoded. Barcode readers contain decoders that calculate the checksum by performing a 
series of mathematical operations on the digits that precede the check digit and compare the result of 
the calculation to the value of the check digit. 

The Object Properties window allows you to insert one or more check digit fields. (There are five 
types of these special check digit fields ISO7812-1, Left-to-Right CK01, Right-to-Left CK01, and 
two others mainly used by those in the health industry: Modulo 43 and Modulo 43 Extended.) 
Although these check digit fields are automatically computed from the data in the Text property, they 
are actually treated as barcode data. Therefore if a barcode contains several check digit fields, 
OnGuard automatically computes and prints multiple checksums for the entire barcode.

1. Open the badge layout by completing the following:

a. From the Layout menu select Open.

b. Select the desired layout and click the [OK] button.

2. Right-click a barcode object and select Properties. The Object Properties window displays. 

3. In the Properties listbox, select “Text”.

4. Click [Insert Field]. The Select Field Type dialog opens. 

5. In the Select Field Type dialog, select “Check Digit” and then click [OK].

6. The Check Digit Field Properties dialog opens. Select the desired algorithm, and then click [OK].

Toolbar button Description

The Barcode Not Rotated button sets the Barcode Rotation attribute for 
selected barcode objects to 0.

The Barcode Upside-Down button sets the Barcode Rotation attribute for 
selected barcode objects to 180.

The Barcode Rotated -90 degrees button sets the Barcode Rotation attribute 
for selected barcode objects to -90.

The Barcode Rotated +90 degrees button sets the Barcode Rotation attribute 
for selected barcode objects to +90 degrees.
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7. The Text field is updated with your selection. Each non-printable ASCII text character inserted 
displays in double-caret brackets and curly brackets: <<{XXX}>>.
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CHAPTER 13 Set Magnetic Stripe, Smart Chip, and 
Shape Attributes
The procedures listed below do not encompass all the magnetic stripe attribute settings and 
procedures.

Set Page Edge

The page edge attribute is available for magnetic stripe objects only and determines the orientation/
offset origin of the magnetic stripe contained on the badge media. The values include: Top (magnetic 
stripe is vertically oriented and offset from the top of the media), Bottom (magnetic stripe is 
vertically oriented and offset from the bottom of the media), Left (magnetic stripe is horizontally 
oriented and offset from the left side of the media) and Right (magnetic stripe is horizontally oriented 
and offset from the right side of the media).

Determine Offset from Edge

The offset from edge attribute is available for magnetic stripe objects only and determines the 
distance (inches or millimeters) between the edge of the badge media and the edge of the magnetic 
stripe. For example, if the page edge attribute for a magnetic stripe is Top then the offset from edge is 
the distance between the top edge of the badge media and the top edge of the magnetic stripe. If the 
page edge attribute is Left, the offset from edge is the distance from the left edge of the badge media 
to the left edge of the magnetic stripe.

Note: The measurement units (inches or millimeters) is set in the Layout Properties folder on 
the Editor form. For more information, refer to Editor Form on page 49.

Geometric Shape and Smart Chip Contact Attribute Procedures

The procedures listed below do not encompass all the geometric shape and smart chip contact 
attribute settings and procedures.
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Set Horizontal and Vertical Fillet Radius

The horizontal and vertical fillet radius is used set rounded corners on the smart chip contact, rounded 
rectangle, photo, signature, and graphic objects. Refer to the examples below of a rounded-rectangle 
with a high value for the horizontal fillet radius and a high value for the vertical fillet radius 
(respectively).

Block Out Printing

The block out printing applies to magnetic stripe objects, smart chip contacts and shape objects 
(rectangle, rounded-rectangle, circle and ellipse). For more information on magnetic stripe objects 
and smart chip contacts, refer to Types of Objects on page 57.

Block Out Printing with Magnetic Stripe and Smart Chip Contacts

Block out printing is a read-only attribute for both the magnetic stripe and smart chip contact; 
therefore this attribute is always set to “Yes” and end-users cannot change it. Please note, however, 
the block out printing attribute is available for shape objects and is NOT a read-only attribute. For 
more information, refer to Block Out Printing with Shape Objects on page 109.

When the block out printing attribute is set to “Yes” it means an object is a blocker object. Blocker 
objects do not allow other objects to intersect them in the BadgeDesigner application as well as 
during the printing process. If another object intersects a blocker object, the part that overlaps the 
blocker object does not display in the application nor is it printed.

In the example below the employee name intersects the magnetic stripe. The badge will be printed 
just as it looks in the display. The employee name will be blocked out where it intersects the magnetic 
stripe. Nothing prints over or on top of the blocker object.
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Notes: The only way to override the read-only attribute (block out printing) for the magnetic 
stripe and smart chip contact is to set their visible attribute to No. When the visible 
attribute is set to No, the magnetic stripe and smart chip contact do not display in 
BadgeDesigner nor do they print on badges.

The visible attribute determines whether the object displays in BadgeDesigner and 
prints on a badge.

Block Out Printing with Shape Objects

Unlike the block out printing attribute for magnetic stripes and smart chip contacts, the block out 
printing attribute for shape objects allows users to toggle the attribute on and off. If the block out 
printing attribute is “Off” then the shape object does not block out printing of objects that intersect it. 
If the block out printing attribute is “On”, then the shape object blocks out printing if the Visible 
attribute is also “On”. Refer to the table below for the results that are achieved for the different block 
out printing and visible attribute settings.These results apply to shape objects as well as magnetic 
stripe and smart chip contacts. 

Block Out Printing Options

Visible Attribute 
Setting

Block Out 
Printing 
Attribute Setting

Result when another object is intersects a shape 
(blocker) object

Yes Yes The shape object displays and blocks out printing. Any 
object that intersects the shape object will be blocked 
from and printing on top of the shape object.

Yes No The shape object does not display and will not block out 
printing. Any object that intersects the shape object will 
display and print on top of the shape object if its layer 
number is closer to the top. For more info 

No No The shape object does not display and will not block out 
printing. Any object that intersects the shape object will 
display and print.

No Yes The shape object does not display and will not block out 
printing. Any object that intersects the shape object will 
display and print.
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Notes: If the Visible attribute is set to “No” the shape object will not display and will not block 
out printing regardless of its Block Out Printing attribute setting.

As with other attributes, the block out printing attribute in conjunction with the visible 
attribute is programmable. For more information, refer to Chapter 14: Program a Badge 
Object on page 111.
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CHAPTER 14 Program a Badge Object
Using the Program Badge feature the properties of an object printed on a badge can be controlled by 
cardholder data. For example, the background graphic used on a badge can be determined by the 
building or location assigned to the cardholder.

Note: If you are not licensed to use the Program Badge feature, OnGuard will remove any 
programming from a badge layout when it is loaded (even if you copied a database from 
a licensed system). You will only be able to edit values for the properties common to all 
objects currently selected in the badge layout. 

Program a Badge Object

1. Determine the cardholder data field that will be associated with the object properties by 
completing the following:

a. Open either the System Administration or ID CredentialCenter application.

b. From the Administration menu select List Builder.

c. In the Lists display field, select the name of a list (cardholder data field). In the example 
below, Department is cardholder data field that will be associated with the object property. 

2. Create a list of options associated with the data field. These options will be available when 
programming a badge as well as creating a cardholder. Refer to the screen shot below.

a. Click the [Add] button.

b. In the List Contents text field, enter the option you want to add to the list.

c. Click the [OK] button. The new item is inserted alphabetically into the List Contents display 
field.

d. Repeat steps a through c for each option to be added to the database.

e. Click the [Close] button.

f. Close the software application.
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3. Launch BadgeDesigner if you have not already done so. If it is already launched, be sure to have 
BadgeDesigner re-scan the database for database field information by completing one of the 
following:

• Pressing <Ctrl> + <U> on your keyboard

• Selecting Update Database Field List from the Layout menu.

4. Open an existing Badge layout by selecting Open from the Layout menu. Select the desired 
layout from the Open Layout window and click the [OK] button.

5. Select the object(s) you wish to program.

6. Open the Object Properties window by completing one of the following:

• Right-click on the badge object and then select Properties.

• Click on the Object Properties  toolbar button 

• Select the Object Properties option from the View menu.

Notes: Depending on your view settings, not all of the options to open the Object Properties 
windows will work. For more information, refer to BadgeDesigner View Options on 
page 52.

A different Object Properties window opens depending on the object selected. For more 
information, refer to Types of Object Property Windows on page 58.

7. In the Object Properties window, select the property (you wish to program) from the Properties 
section. In the example below, Fill Color is selected. 

Lists display 
field

List 
Contents 
text field

List 
Contents 
display field
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8. Select the controlling field from the drop-down list at the bottom of the Object Properties 
window. This is the cardholder data field that you selected in step 1. The controlling field 
determines which set of data will be used to program the badge property. In the example above, 
Department is selected as the controlling field.

9. Select a controlling field value to program from the Programmed value section. This is the list of 
options you associated with the cardholder data field in step 2. In the example above, the 
Engineering controlling field value is selected (highlighted).

10. In the lower right portion of the Object Properties window, set the property value for the 
controlling field value you selected in step 9. In the example above, the color red is selected and 
associated with the Engineering department.

11. Repeat steps 9 and 9 for each value in the Programmed value section.

12. Repeat steps 7 through 10 to program additional object properties.

13. Click the [OK] button when you are done. 

14. Save your changes to the BadgeDesigner database by clicking the Save Layout  toolbar 
button or selecting Save from the Layout menu.

A Program Badge Example

Suppose you want the cardholder’s department printed below the cardholder’s picture and you want 
the fill color for the departments color coded.

Department Color

Engineering Red

Manufacturing Orange

Marketing Yellow

Sales Green

Training Blue

7. Properties 
section

8. Controlling 
field drop-down 
list

9. Programmed 
value section

10. Section to
program the 
controlling fie
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You would perform the following steps:

1. First, define the department list field values in the List Builder. 

a. Open the List Builder window via the System Administration or ID CredentialCenter 
software applications.

b. Select the name of the list (in this case, “Department”) and click the [Add] button.

c. Enter several types of departments (in this case you would add Manufacturing, Engineering, 
Marketing, Sales and Training.)

d. Click the [OK] button.

e. Close the software application.

2. Launch BadgeDesigner if you have not already done so. If you have, either press <Ctrl> + U or 
select Update Database Field List from the Layout menu to re-scan the database.

3. Open an existing badge layout or create a new layout. For this example we will create a new 
layout. For more information, refer to Chapter 4: Create, Open and Save Layouts on page 37.

4. Insert a photo with a text object underneath.

5. Select the text object. 

6. Open the Object Properties window. 

7. Program the Text property to display the department name. To do this:

a. Select Text from the Properties section.
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b. Select Department from the Controlling Field drop-down list.

8. Assign text values to the different departments.

a. Select the “Engineering” department in the Programmed value section.

b. In the lower right portion of the Object Properties window, enter Engineering.

c. Continue assigning text values to each department.

d. When you are finished the object properties window should like the following:
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Note: Click on the different programmed values in the lower left corner of the Object 
Properties window. Notice the Preview window (upper right corner of the Object 
Properties window) displays the different text values.

9. Program the fill color to display colors by department.

a. Set the Fill Style to solid.

• Select (highlight) Fill Style in the Properties section (upper left corner of the Object 
Properties window).

• Click the Fill Style drop-down list in the lower right corner of the Object Properties 
window and select the solid fill style (just below the No Fill option).

b. Select Fill Color from the Properties section.

c. Select Department from the Controlling Field drop-down list.

9b.
9a.
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10. Assign color values to the different departments. Refer to Department on page 113 for the 
appropriate colors.

a. Select the “Engineering” department in the Programmed value list.

b. Press the [Select] button in the Fill Color section (lower right corner of the Object Properties 
window).

c. Choose red. Now the text object’s fill color property is programmed to display red for 
cardholders in the Engineering department and white for all others (because in this example 
white is the default value).

d. Continue assigning colors to each department.

11. When you are finished the Text Object Properties window should match the following:

12. You can now click on each department listed in the Programmed value section and watch the 
object preview change to show the different programmed fill colors and text. 

13. Click the [OK] button to exit from the Object Properties window.

14. Save these values to the BadgeDesigner database by choosing Save from the Layout menu or by 

clicking on the Save Layout  toolbar button.
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CHAPTER 15 BadgeDesigner Gallery
The BadgeDesigner Gallery displays a miniature view of every badge layout in the BadgeDesigner 
database. You can use the BadgeDesigner Gallery to open, rename, import, export and delete badge 
layouts in the BadgeDesigner database.

Note: The BadgeDesigner Gallery is also called the Badge Layouts in Database window.

Open the Gallery Window

From the Layout menu select Gallery or use the following shortcut keys: <Ctrl> + <G>.
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Select a Layout And Deselect All Other Layouts

1. From the Layout menu select Gallery or use the following shortcut keys: <Ctrl> + <G>.

2. Click on a thumbnail. A red border displays around the view, indicating it is selected. Any layout 
or layouts that were previously selected are now deselected.

Select a Layout Without Deselecting Other Layouts

1. From the Layout menu select Gallery or use the following shortcut keys: <Ctrl> + <G.

2. Hold down the <Ctrl> key and click on a thumbnail. A red border is displayed around the view, 
indicating that it is selected.

3. Repeat step 2 to select additional layouts.

Select Several Layouts in a Sequence

1. From the Layout menu select Gallery or use the following shortcut keys: <Ctrl> + <G.

2. Click on the first thumbnail in the layout view.

3. Hold down the <Shift> key and click on the last thumbnail in layout view. A red border is 
displayed around all views, indicating that they are all selected.

Deselect a Layout

Click the mouse anywhere in the layout view. The red border around the view is removed, indicating 
that the layout is no longer selected.

Open a Layout

1. From the Layout menu select Gallery or use the following shortcut keys: <Ctrl> + <G.

2. Select the appropriate layout view (thumbnail) by clicking on it.

3. Click the [Edit] button or double-click the mouse anywhere in the BadgeDesigner Gallery 
window.

4. The layout is opened in the BadgeDesigner window.

Open Several Layouts

1. Select the layout(s) to be opened. Be sure to use the <Shift> or <Ctrl> keys to select multiple 
layouts.

2. Click the [Edit] button. The selected layouts open in the BadgeDesigner window.

Rename Layouts

1. Select one layout to be renamed.

2. Click the [Rename] button. The Rename Layout window opens.
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3. Type the new layout name in the New Name field and click the [OK] button. The Rename 
Layout window closes and the layout is renamed.

Delete Layouts

To delete one or more layouts from the database:

1. Select the Gallery option under the Layout menu. The Layout Gallery appears.

2. Select the layouts to be deleted and click the [Delete] button.

3. The Confirm Layout Delete window opens. Click the [Yes] button to confirm the deletion. The 
Confirm Layout Delete window closes and the selected layouts are deleted from the 
BadgeDesigner database.

Export Layouts

A BadgeDesigner badge layout can be exported to any system drive so that it can be imported to 
another system where BadgeDesigner is installed.

When a layout is exported, the following files are copied to the selected system drive:

• The “.bdg” layout file (Layout Name.bdg)

• A “.jpg” file for each true-color graphic contained in the badge layout (Graphic Name.jpg)

• A “.png” file for each paletted graphic contained in the badge layout (Graphic Name.png)

• A “.png” mask file for each chromakeyed graphic contained in the badge layout (Graphic 
NameMask.png).

To export a layout:

1. Select one layout to be exported.

2. Click the [Export] button. The Select Folder window opens. 

3. Navigate to the folder into which the layout is to be exported using the [Open] button.

4. When you reach the desired folder location, click the [Save] button. The Select Folder window 
closes and the layout is exported to the selected folder.

Import Layouts

BadgeDesigner badge layouts can be imported into the BadgeDesigner database from any system 
drive.

When a layout is imported, the following are copied into the database:

• The layout itself (from the “.bdg” file)

• A graphic for each “.jpg” file and “.png” file
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• A chromakey mask for each “Mask.png” file.

To import a badge layout into the BadgeDesigner database:

1. Click the [Import] button. The Open window opens.

2. Select the “.bdg” file to be imported and click the [Open] button. The Open window closes and 
the selected badge layout is imported into the BadgeDesigner database.

Edit Layouts

To edit a badge layout:

1. Select the Gallery option under the Layout menu. The Layout Gallery appears.

2. Select the layouts click the [Edit] button. The badge displays in the BadgeDesigner main 
window. 

3. Edit the sample badge. For more information, refer to Add, Select and Delete Badge Objects on 
page 57.

4. When you are done, save the layout by clicking Save in the Layout menu.

Refresh the Gallery Window

The BadgeDesigner Gallery window can be updated or refreshed, at any time, to display the most 
current layouts in the BadgeDesigner database. This is useful if you are using BadgeDesigner with a 
shared database.

To refresh the BadgeDesigner Gallery Window:

• Click the [Refresh] button. The BadgeDesigner Gallery window is refreshed.

Close the Gallery Window

To close the BadgeDesigner Gallery Window:

• Click the [Close] button. The BadgeDesigner Gallery window closes.
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APPENDIX A Multimedia Capture
Multimedia Capture contains forms with which you can:

• Import an existing photo

• Optimize photo image quality

Required Licenses and Permissions

The availability of certain features in Multimedia Capture are subject to licensing restrictions. A 
user’s permissions must also be set on the Cardholder Permission Groups form in the Users folder. 
For more information, refer to the Users Folder chapter in the System Administration User Guide. 

Multimedia Capture feature Required license

Required Cardholder 
Level capture 
permission

Image Processing window Image Capture (STD) Image Processing

WDM Video capture source Image Capture (STD) Photo

FlashPoint/MCI Video capture source Image Capture (STD) Photo

WDM Video Settings, FlashPoint/MCI 
Video Settings and FlashPoint/MCI 
Video I/O Settings sub-tabs

Image Capture (STD) Photo and Advanced

Scanner & Digital Camera capture 
sources

Image Capture (STD) Scanner

Scanner & Digital Camera Settings 
sub-tabs

Image Capture (STD) Scanner and Advanced

Signature capture source Image Capture (STD) Signature

Signature Settings sub-tab Image Capture (STD) Signature and 
Advanced
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Note: The BadgeDesigner application does not use the following permissions: File Import, 
Signature, File Export, Biometrics and Advanced. Users with permission to use 
BadgeDesigner are automatically authorized to perform layout graphic file import, 
export and use the General Settings tab.

Graphic Form

The Graphic form is for capturing badge layout graphics to be used in badge layouts. You can control 
if and how the system determines background transparency information for the currently captured 
bitmapped image (does not apply to non-bitmapped (vector) images.) Badge printing/print-preview 
will use this transparency information when told to print/display just the foreground portion of that 
image onto the badge. A typical application of this feature is to print just the head and shoulders of 
employees, often on top of some graphics. Setting the tolerance to zero causes no transparency 
information to be stored for the image into the database.

Capture Source
Select the type of information you want to capture. Choices include:

• WDM Video - the cardholder’s photo is captured from live video. When you select the 
WDM Video capture source, the WDM Video Settings sub-tab becomes available.

• Flashpoint/MCI Video - the cardholder’s photo is captured from live video. When you 
select the FlashPoint/MCI Video capture source, the FlashPoint/MCI Video Settings sub-
tab becomes available.

• Signature - the cardholder enters his or her signature using a signature capture tablet and 
stylus. (This option is only available when Signature form is selected.)

• Scanner - a scanner device creates a computer image file from an existing hardcopy photo. 
When you select the Scanner capture source, the Scanner Settings sub-tab becomes 
available.
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• Digital Camera - a digital camera is attached to the computer so that images stored in the 
camera can be transferred to the system. When you select the Digital Camera capture 
source, the Digital Camera Settings sub-tab becomes available.

• File Import - an existing computer image file is added to the system.

Processing Profile
Select an effect profile for the selected image. Effect profiles are defined in the Image 
Processing window. Click [Process] to open the Image Processing window. They system is 
configured with a set of default image processing profiles that can be applied. 

Multimedia window
Depending on your selection from the Capture Source drop-down list, this window displays 
either live video, signature input, scanner input, a digital camera image or an imported file. 

Export
Click this button to save the current captured image as an image file on a disk. Minimal 
compression will be used so that the image is stored in the best possible quality. The crop 
window will be used when exporting if an image is bitmapped. The following default filename 
and extensions apply when exporting:

When the Photo form is selected:

• If the photo is bitmapped and the crop window is in use, the portion of the image within the 
crop window will be saved. Otherwise, the whole photo will be saved.

• If the current record has no name assigned to the cardholder, the filename default is 
“no_name Photo.” Otherwise, the filename will default to the cardholder’s name.

• When the Signature form is selected:

• If the signature is bitmapped and the crop window is in use, the portion of the signature 
within the crop window will be saved. Otherwise, the whole signature will be saved.

• If the record has no cardholder name, the filename default is “no_name Sig” plus the 
filename extension. Otherwise, it defaults to the cardholder name plus the filename 
extension.

• When the Graphic form is selected:

• If the graphic is bitmapped and the crop window is in use, the portion of the graphic within 
the crop window will be saved. Otherwise, the whole graphic will be saved.

• If the graphic is a new one being imported into the database, the filename default is “New 
Layout Graphic” plus the filename extension. Otherwise, it defaults to the graphic name 
plus the file extension.

Freeze
Select this button to freeze the live video in order to capture a cardholder's photo. This button 
is displayed only when either “WDM Video” or “FlashPoint/MCI Video” is selected from the 
Capture Source drop-down list.

Unfreeze
Select this button to resume live video. This button is displayed only when either “WDM 
Video” or “FlashPoint/MCI Video” is selected from the Capture Source drop-down list.

Open
Click this button to display an Open window from where you can select a drive, directory and 
filename to import an existing photo. This button is displayed only when “File Import” is 
selected from the Capture Source drop-down list.
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Clear
Click this button to clear the contents of the multimedia window. This button is displayed only 
when “Signature,” “Scanner,” “Digital Camera”, or “File Import” is selected from the 
Capture Source drop-down list.

Sign
Click this button to activate the signature pad so that the cardholder can enter his or her 
signature. This button is displayed only when “Signature” is selected from the Capture 
Source drop-down list.

Stop
Click this button to notify the system that the cardholder has finished entering his or her 
signature and deactivate the signature pad. This button is displayed only when “Signature” is 
selected from the Capture Source drop-down list.

Preview
Click this button to activate the scanner, so that the existing image can be digitized (scanned) 
into the system. This button is displayed only when “Scanner” is selected from the Capture 
Source drop-down list.

Scan
Click this button to activate the scanner, so that the existing image can be digitized (scanned) 
into the system. This button is displayed only when “Scanner” is selected from the Capture 
Source drop-down list.

Process
Click this button to open the Image Processing window from where you can manipulate the 
captured photo to improve its quality.

Save User Defaults
Click this button to save the current settings as the default settings on this workstation. The 
settings will be applied to all Multimedia Capture forms and sub-tabs; however, they do not 
include the set of image processing profiles, which are maintained separately by the Image 
Processing window.

Show Admin Settings
Select this button to view all the forms and sub-tabs applicable to the current capture source. 
When not selected, only the Chromakey and Effects Gallery sub-tabs will be displayed.

Load User Defaults
Click this button to display the previously saved (default) settings for this workstation. The 
settings will be applied to all Multimedia Capture forms and sub-tabs.

Load Factory Defaults
Click this button to open the Load Factory Defaults window where you can reset the capture 
settings back to the default values for your specific capture hardware.

OK
Saves your changes and closes Multimedia Capture.

Cancel
Closes the window and returns you to the Cardholder, Badge or Access Levels form. Does not 
save any changes made in Multimedia Capture.
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Help
Displays online assistance for Multimedia Capture.

General Capture Procedures

The following procedures can be used on this form.

1. In BadgeDesigner, display a badge layout.

2. Select a graphic in the badge layout.

3. Select Object Properties from the View menu.

4. The graphic Properties window displays. 

5. Click [Gallery]. The Select Graphic from Database window displays.

6. Click [Import]. Multimedia Capture opens. 

Load (User or Factory) Default Settings

1. In Multimedia Capture, click the Photo, Signature, or Graphic tab. 

2. Click [Load Factory Defaults] or [Load User Defaults]. 

3. If you are loading user defaults, the settings automatically populate.

4. If you are loading factory default settings, the Load Factory Defaults dialog opens.

a. Select the profile for the hardware capture device.

Note: The difference between high resolution and low resolution digital camera profiles is that 
they have different default crop window sizes.

b. Click [OK]. 

Export an Image

OnGuard exports the most recently saved image. Even if you are displaying live video or recording a 
signature at the time you initiate export, OnGuard exports the last image saved. If the image is 
cropped, only the cropped portion is exported.

1. In Multimedia Capture, click the Photo, Signature or Graphic tab.

2. Display the image and click [Export].

3. Depending on how the system is configured, the Save As window opens. Enter the filename and 
click [Save]. Otherwise, the file is automatically named and exported to the default directory set 
up in the Multimedia Capture admin settings (File I/O Settings sub-tab).

Formats Exported

OnGuard exports images in the following formats:

• JPG format if the image is bitmapped and has more than 256 colors.

• PNG format if the image is bitmapped and has 256 colors or less.

• EMF format if the image is vector.
System Administration User Guide 129



Multimedia Capture

130
Chromakey Sub-tab

The Chromakey sub-tab allows you to control if and how the system determines background 
transparency information for bitmapped images. Chromakey does not apply to non-bitmapped 
(vector) images.

A typical application of chromakey is to capture cardholder/visitor images using a solid color 
backdrop. Then, apply chromakey to the images (remove the background color) and print the badge. 
The cardholder/visitor’s image displays over the background image.

Chromakey output
Displays the image with the current Chromakey settings applied. When printing a badge, you 
may want to first preview the badge and zoom in to enlarge the display, to make sure that your 
Chromakey settings produced the desirable result.

Key to Origin on Clear (Right-Click to Set)
Controls the position of the key (red cross-hairs) upon loading of a new image. The key 
position is selected using the mouse to right-click over the image. When this check box is 
selected, when the current image is cleared, the key position is reset to the origin (at the top 
left corner of the crop window). When this check box is not selected, when the current image 
is cleared, the key position is preserved.

Fit to Window Size
When this check box is selected, the current image is scaled to fit within the available viewing 
area. Depending on the size of the image, it will be reduced or enlarged to fit the window.

Full Color Remove
When this check box is selected, the chromakey feature will determine which pixels are 
background pixels strictly by color matching alone. Every pixel of the image is compared 
against the key color, from left-to-right, top-to-bottom. Each pixel that differs from the key 
color is determined to be a background pixel. The tolerance setting determines how much the 
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colors have to differ from the key color to be considered as background. When this check box 
is not selected, the chromakey feature will determine which pixels are background pixels in 
the same manner as a drawing program’s flood-fill feature. The filling starts at the origin and 
spreads outward, stopping at parts of the image that differ from the key color. The tolerance 
setting determines how much the colors have to differ to stop the fill. 

Full color remove works well with graphic images but not with photos when the color of the 
person’s eyes or clothing is very similar to the background color.

Tolerance (0-255) 
Determines how much deviation from the exact chromakey color match is tolerable. Choose a 
value in the range of 0-100. The higher the tolerance value the more colors that will be 
chromakeyed out (the more colors that will be converted to background).

Chromakey Sub-tab Procedures

The following procedures can be performed on this form.

Apply Chromakey to an Image

Note: Chromakey is available only when the captured image is bitmapped.

1. In Multimedia Capture, display an image.

2. On the Photo or Graphic tab, click the Chromakey sub-tab.

3. In the main window, identify the color you want to make transparent by right-clicking the mouse 
over the original image (and inside the crop window if there is one). When you right-click, a red 
cross hair displays or repositions itself. The red cross hair identifies the color the chromakey 
tolerance value applies to.

4. On the Chromakey sub-tab:

a. Select the Fit to Window Size check box if you want to view the entire image in the 
Chromakey window.

b. Select the Full color Remove check box to remove the selected color from the entire screen. 
This feature works well with graphic images but not photos where the person’s eye color 
may match the background you are trying to remove.

c. Use the Tolerance slider to control the depth of the chromakey effect. The Chromakey 
window displays the changes.

d. Use the Key to Origin on Clear (Right-Click to Set) check box to reset the cross hair 
position to the top left corner of the image when you click [Clear].

5. Click [OK].

Chromakey Tips

The following characteristics produce the best chromakey results:

• High quality images

• Deep blue or green (highly saturated) backgrounds (light gray and white do not work well)

• Uniform background lighting

• No shadows

• Background color significantly different than the subject’s eye and clothing color
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Effects Gallery Sub-tab

The Effects Gallery displays up to six pre-defined effect profiles. Choices include: increase or 
decrease hue, increase or decrease saturation, increase or decrease contrast, and sharpen. An effect 
profile contains special effects that can be applied to bitmapped images only. 

You can also customize an effect profile. When you customize an effect profile you can choose from 
21 different effects. Furthermore, many of these effects have settings that allow you to increase or 
decrease the intensity of that effect. Multiple effects can be combined to achieve the desired result. 
For more information, refer to Create an Effect Profile on page 136.

Use the Effects Gallery

1. In Multimedia Capture, display an image.

2. On the Photo or Graphic tab, click the Effects Gallery sub-tab.

3. Select an effect profile from the drop-down list.

4. To apply the effect on the currently displayed image, select the thumbnail image such that a blue 
line encompasses the perimeter of the thumbnail.
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Image Processing Window

Preview boxes
Any of the six boxes each containing a thumbnail of the captured image with an effect profile 
applied.

Effect profile
Choices in these drop-down lists (located below the six thumbnails of the captured image) 
include the names of all currently defined effect profiles. Select a profile to be applied to each 
thumbnail.

Image Processing Window

Original Image
Displays a miniature view of an original (unprocessed) captured image.

Processed Image
Displays a miniature view of an image with an effect profile applied. This enables you to 
preview the outcome of combined image effects.

Effect Library
Lists the available effects you can apply to the captured image. Choices include:

• None - applies no effects to the image.

• Intensity - increases or decreases the overall intensity level of the light in the image. Adjust 
the brighter areas by making them brighter or darker. You can choose a value in the range 
of -100% to +100%. Negative values make the image darker; positive values lighten the 
image.

• Contrast - increases or decreases the range of gray levels contained in the image, adjusting 
the distinction between the lightest and darkest tones in the image. You can choose a value 
in the range of -100% to +100%. The higher the positive value the lighter the light areas 
become and the darker the dark areas become.
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• Saturation - adjusts the purity of color (the number of colors used to create a particular 
color). You can choose a value in the range of -100% to +100%. Positive values increase 
the saturation (purity); negative values decrease the saturation.

• GammaCorrect - enhances detail in the image by adjusting the middle tones without 
affecting the darkest and lightest areas. You can choose a gamma value in the range of 1 to 
499. The larger the number, the greater the adjustment will be.

• HistoContrast - adjusts the number of pixels per gray level to create a linear relationship 
between gray levels. This effect can bring out the detail in dark areas of the image. You can 
choose a value in the range of -100% to +100%.

• Hue - adjusts the main characteristic of a particular color that distinguishes it from other 
colors. You can choose a value in the range of -360 to +360.

• HistoEqualize - redistributes shades of colors to adjust imbalances. It makes the darkest 
colors black and the lightest colors white and stretches the colors in between. It is often 
best to equalize a scanned image first to improve its appearance before applying other 
effects.

• Flip - flips the image horizontally (the image will appear upside down).

• Reverse - flips the image vertically, creating a mirror image of the original. 

• Rotate - you can choose a value in the range of -360 to +360. Negative values rotate the 
image counterclockwise. Positive values rotate the image clockwise.

• Shear - applies the look of three-dimensionality to the image, while maintaining the 
original size and shape. You can choose a value in the range of -45 to +45. Negative values 
apply the effect to the top and left directions, positive values apply the effect to the bottom 
and right directions. Shear applies its effect only along the horizontal and vertical planes.

• AddNoise - creates a granular effect that adds texture to a flat or overly blended picture. 
You can choose a value in the range of 0 to 100.

• Average - converts each pixel in the image to the average of itself and the pixels to the 
right and bottom. The result is a blurring of the image. You can choose a value in the range 
of 1 to 100.

• Sharpen - enhances the edges and brings out detail. The higher the number, the greater the 
sharpening. You can choose a value in the range of -100 to +100.

• Halftone - converts the image to a black and white (1 bit/pixel) image in which different 
shades of gray (luminances) are represented by different patterns of back and white pixels. 
Denser dot patterns of white represent higher luminances (lighter areas of the image). 
Denser dot patterns of black dots are used represent lower luminances (dark areas of the 
image). Adjusting the slider adjusts the angle of the dot patterns (from 0 to 360 degrees). 
Simulates the image's continuous tone quality using varying hues and combinations of the 
process (subtractive) colors. You can choose a value in the range of -360 to +360.

• Median - reduces the amount of graininess in an image. It does so by converting each pixel 
in the image to the midpoint of itself and some number of pixels to the right and bottom. 
The result is a blurring of the image. You can choose a value in the range of 1 to 100.

• Emboss - converts the image to a raised relief style with its light source directed from the 
top left. The slider adjusts the depth of the embossing. You can choose a value in the range 
of 0 to 100.

• Grayscale - represents the image using up to 256 shades of gray.

• Invert - inverts the colors in the image as on a photographic negative.

• Mosaic - converts the image to a grid of square blocks of color. You can choose a value in 
the range of 1 to 100. The higher the number, the larger the blocks will be.

• Posterize - reduces the color resolution, which is the number of shades of color that can be 
displayed simultaneously. Gradations are removed, creating areas of solid colors or gray 
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shades. You can choose a value in the range of 2 to 64. The lower the number, the more 
pronounced the effect will be.

Value type
Use the slider to adjust the value of the effect selected in the Effect Library listing window. 
You can also type in a numeric value. Note that some effects are not adjustable.

Add
Click this button to add the item to the Effect Profile listing window.

Click this button to remove the effect from the Effect Profile listing window

Click this button to move the effect up one position in the effect profile.

Click this button to move the effect down one position in the effect profile.

Effect Profile listing window
Lists the sequence of effects that will be performed to produce the combined effect selected in 
the profile list.

Profile list
Lists all currently defined effect profiles.

OK
Saves your changes and close the Image Processing window. 

Cancel
Closes the Image Processing window without saving your changes.

Help
Displays online assistance for this window.

Apply
Applies the current effect profile to the original image and display the results in the Processed 
Image window for comparison.

Delete Profile
Removes the selected profile from the profile list

Save Profile
Saves the current profile and add it to the profile list.

Effects Gallery Sub-tab Procedures

The following procedures can be performed on this form.
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Create an Effect Profile 

1. In Multimedia Capture, display an image.

2. Verify the Processing Profile drop-down list (upper right) is empty. Otherwise, you will be 
modifying an existing profile instead of creating a new one.

3. On the Photo or Graphic tab, click [Process]. The Image Processing window opens.

4. Select an entry in the Effect Library listing window. If the effect is adjustable, proceed to step 5. 
If the effect is not adjustable, proceed to step 6.

Note: The effect is adjustable if one or more fields display below the Effect Library listing 
window. 

5. Adjust the intensity of the effect. 

6. Click [Add] to add this effect to your new profile.

7. Repeat steps 4-6 for each effect you want to add to the new profile.

8. To view the result of the entire effect profile, click [Apply].

9. Enter the name of the new profile and click [Save Profile]. 

10. Click [OK].

Modify an Existing Effect Profile

1. In Multimedia Capture, display an image.

2. On the Photo or Graphic tab, click [Process]. The Image Processing window opens.

3. Select the effect profile from the drop-down list.

10

8

9

6

4

5
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4. To delete the effect, click .

5. To change the value of the effect, you must delete the effect first and then add the effect with a 
new value. 

For example, if you have an effect that sharpens an image by a value of 10 and you want to 
modify it to sharpen the image by a value of 12, you cannot simply change the value of the effect. 
You must first delete the sharpen effect with a value of 10 and then add the sharpen effect with 
the value of 12.

6. To change the order effects display, select an effect, and click the correct button.

•  Moves the entry up one position in the list.

•  Moves the entry down one position in the list.

7. Click [Save Profile].

Delete an Effect Profile

1. In Multimedia Capture, display an image.

2. On the Photo or Graphic tab, click [Process]. The Image Processing window opens.

3. Select an entry from the profile list drop-down list.

4. Click [Delete Profile].

General Settings Sub-tab

The General Settings sub-tab allows you to configure:

• Which capture source (view) is automatically selected when the capture window is launched.

• Whether or not the settings will be automatically shown when the capture window is launched.

• Whether automatic cropping will be used.

• Whether manual cropping will be used.

• For automatic cropping: whether cropped images will be automatically rotated so that the eyes 
are level in the photograph.

• The amount of compression to be applied to bitmapped images with more than 256 colors before 
they are stored in the database.
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Note: Image cropping only applies to bitmapped images (also known as raster images). It is 
NOT recommended to crop vector images.

• The size, location, and behavior of the crop window (the rectangle used for specifying which 
rectangular portion of the current image will be stored into the database or exported to an image 
file on disk).

• The units used when displaying the width and height of the portion of the image that will be 
stored in the database or exported to an image file on disk.

• The aspect ratio of the automatic crop window.

Show Settings by default
When this check box is selected, all settings sub-tabs applicable to the current capture source 
will be displayed. When this check box is not selected, only the Chromakey and Effects 
Gallery sub-tabs will be displayed. If you change the value of this field, you must click [Save 
User Defaults] button for the change to take effect.

Default Capture Source
From the drop-down list, choose which capture source you want the system to automatically 
default to when Multimedia Capture opens.

Default Processing Profile
From the drop-down list, choose which effect profile you want to apply to the captured image 
when no effect profile is chosen. Effect profiles are defined in the Image Processing window.

Compression Amount ___%
Enter the amount of compression to be applied to the captured bitmapped image (i.e. 
cardholder photo, bitmapped signature or layout graphic). A captured photo contains a great 
deal of color information so a large amount of computer disk space is required to store the 
photo. Compression is the process of reducing the disk space requirement.

You can choose a number between 0 and 100 to balance compression and image quality. 
Entering 0 (minimal compression) will yield the highest quality image with the largest disk 
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space requirement. Entering 100 (maximum compression) will result in the poorest quality 
image, but it will take up very little disk space. Refer also to the Test push button. The default 
value for this field is 10.

Compression applies only to bitmapped images with more than 256 colors. A different 
compression (PNG) is used for bitmapped images with 256 colors or less, which has a fixed 
quantity.

Test
Click this button to open the Test Compression window from where you can adjust the 
captured bitmapped image to achieve the best balance of image quality and disk space 
required. This applies only to bitmapped images with more than 25 colors.

Crop Window
The crop window displays as a rectangle superimposed over the multimedia window. It is used 
to select the portion of the captured image that will be saved or exported. With manual 
cropping, you can change the size and position of the crop window to best frame the subject. 
With automatic cropping, the frame is automatically sized and positioned to produce a well 
cropped image. However, you can override the cropped window using the manual crop sizing 
functions. Image cropping applies only to bitmapped images. It is not recommended for vector 
images.

Enable automatic cropping
When this check box is selected, the crop window is automatically displayed, cropping the 
captured photograph to frame the face and shoulder area of the subject. The cropped image 
area is pre-configured based on the default Aspect ratio setting.

During automatic cropping, each photograph is analyzed to ensure that it satisfies the 
conditions required to produce a well cropped image. For more information, refer to Image 
Requirements for Automatic Cropping on page 141.

Aspect ratio
Select the aspect ratio (height-to-width) for the crop window or create a custom setting. 
Aspect ratios can be expressed as ratios, such as 4:3, or as numbers, such as 1.33. Available 
options include:

• Badge - select to use an Aspect ratio of 1.33 for badge images and several types of 
driver’s licenses.

• Passport - select to use an Aspect ratio of 1.28 to satisfy requirements for other types of 
driver's licenses and numerous international passport agencies.

• Mugshot - select to use an Aspect ratio of 1.25.

• Custom (User defined) - When this option is selected, the field containing the value of the 
Aspect ratio is enabled allowing you to type in your desired aspect ratio (may be 
configured within a range of 1.25 to 1.34).

Rotate image
For automatic cropping: select to enable automatic image rotation. If needed, the captured 
image will be automatically rotated such that the eyes are level in the photograph.

Enable manual cropping
When this check box is selected, the crop window is displayed. Otherwise, the crop window is 
hidden, the whole captured image is saved or exported, and the Sizable and Maintain Aspect 
fields is dimmed.
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Sizable
When this check box is selected, the crop window can be resized. This means that the values 
of the Width and Height fields can be changed. Manual crop adjustment may be used in 
conjunction with automatic cropping.

Maintain Aspect
When this check box is selected, the width-to-height ratio of the crop window will remain 
consistent (when you change the width, the height changes proportionally and vice versa). For 
example, if the width and height of the crop window are in the ratio of 2:3 and you enter a 
value of 67 for the width, the height will automatically become 100 if the Maintain Aspect 
check box is selected. This is because 67 and 100 have a 2 to 3 relationship. For more 
information, refer to the topic “Set Aspect Ratio Attributes” in the BadgeDesigner User 
Guide.

Units
Select the measurements in which the size is displayed. Choices include pixels, inches or 
millimeters.

Left
Sets the position of the left border of the crop window. You can also move the left border 
directly and this value will be automatically updated to reflect the change.

Top
Sets the position of the top border of the crop window. You can also move the top border 
directly and this value will be automatically updated to reflect the change.

Width
Sets the width of the crop window. You can also move the left or right border directly and this 
value will be automatically updated to reflect the change.

Height
Sets the height of the crop window. You can also move the top or bottom border directly and 
this value will be automatically updated to reflect the change.

General Settings Sub-tab Procedures

The following procedures can be performed on this form.

Enable Automatic Cropping

Automatic cropping places the crop window to automatically frame the face and shoulder region in 
the cardholder's photograph. Green crosshairs are displayed to mark the eye locations in the photo.

With automatic cropping, cropped image resolution is based on a selectable, pre-configured aspect 
ratio which provides standardized cropping across all cardholders and requires less time and effort 
from the badge operator.

To enable automatic cropping, select the Enable automatic cropping check box on the General 
Settings sub-tab.

Assumptions:

• Photos are captured of the cardholder's head including at least the top of the shoulders.
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• The cardholder’s eyes must be visible.

• There is only one face in the image.

• The background is not too busy.

• The image is in color.

Automatic Image Rotation

If the Rotate image check box is selected, the captured image is automatically rotated such that the 
eyes are level in the photograph.

Image Requirements for Automatic Cropping

If a captured image meets the requirements for automatic cropping, the crop window is displayed. 
However, if the requirements for automatic cropping are not met, an error message is displayed 
describing the adjustments which need to be performed. Additionally, the crosshairs used to locate the 
eyes are red rather than green to indicate an error has occurred. For example, if the cardholder is too 
close to the capture device an error is generated.

• The image dimensions must not be too small.

Minimum image resolution for automatically cropped images must be no less than 242 x 322 
pixels (width x height). Typically, smaller images have been imported. In practice, a minimum 
image resolution of 640 x 480 is recommended.

• The image dimensions must not be too large.

A warning is reported if the image resolution is greater than two (2) megapixels (e.g., 1600 x 
1200 pixels). Large images require a considerable amount of time to process and it is 
recommended to decrease the image resolution. The operator is given the option to continue or to 
stop processing.

• The eyes of the cardholder must be located in the image.

• The cardholder’s head must not be too close to the left or right edge of the photograph.

• The cardholder’s head must not be too close to the top or bottom edge of the photograph.

• The cardholder must not be too far away from the capture device.
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The farther the cardholder is located from the capture device, the less the distance between the 
eyes. There must be a minimum eye separation of 60 pixels to produce acceptable quality 
images.

• The cardholder must not be too close to the capture device.

You must be able to fit the crop window within the image.

• The cardholder’s head must not be tilted side-to-side more than 17º for eye location.

Correct Imperfect Eye Detection

The crosshairs displayed on the eye locations allow you to accurately correct imperfect eye detection 
by re-sizing the crop window. For more information, refer to Resize the Crop Window on page 142.

IMPORTANT: Manual adjustment of the crop window may be done using the Height and 
Width controls but this will cause the default aspect ratio to be overridden. For 
more information, refer to Prevent Manual Crop Adjustment on page 143.

Enable Manual Cropping

You can manually crop images if manual cropping is enabled and the image is bitmapped. To enable 
manual cropping, select the Enable manual cropping check box on the General Settings sub-tab. 
The crop window will display in the image. If you cannot see the crop window, it may be so large that 
it encompasses the entire image. Simply resize the crop window.

Resize the Crop Window

To resize the crop window, the Sizable check box must be selected on the General Settings sub-tab. 

You can resize the crop window using your mouse or, if more accuracy is required, you can enter the 
exact width and height of the crop window on the General Settings sub-tab.

To resize the crop window using your mouse, hover the mouse over the perimeter of the crop window. 
In some cases, the crop window encompasses the entire image you so may need to hover the mouse 
over the perimeter of the image. When the cursor changes to a double arrow, left-click on the crop 
window and drag it to the desired size.

Move the Crop Window

If the crop window is enabled, you can move the crop window using your mouse. Simply place the 
cursor inside the crop window, left-click and drag the crop window to the new location.

If more accuracy is required, you can enter the exact coordinates of the crop window on the General 
Settings sub-tab. Crop window coordinates are relative to the distance from the left side of the image 
and the distance from the top of the image. Crop window coordinates and unit of measure are entered 
on the General Settings sub-tab. 

Adjust Image Compression

The following procedure applies only to images that are bitmapped and contain more than 256 colors.

1. In Multimedia Capture, display an image.

2. On the Photo, Signature or Graphic tab, click the General Settings sub-tab.
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Note: The [Show Admin Settings] button must be depressed in order to view the General 
Settings sub-tab.

3. If your capture source is live video, click [Freeze] because compression can be applied only to 
still images. Otherwise, skip to step 4.

4. On the General Settings sub-tab, click [Test]. The Test Compression window opens. The left 
image is uncompressed and the right image is compressed. 

5. Adjust the Compression Amount slider to achieve the optimal balance between the amount of 
compression and image quality. Moving the slider to the right (higher numbers) increases the 
amount of compression and lowers both the image quality and the database space required. Each 
time you reposition the slider, click [Compress] to see the effect on the image.

6. When you find the best balance between image quality and disk space, click [OK].

Prevent Manual Crop Adjustment

Permissions must be set to allow the badge operator to manually adjust the crop window.

To prevent operators from manually performing crop adjustment, and thereby overriding the crop 
window, permissions are provided to lock the usage of the Manual crop function. The Advanced 
option of the Capture Cardholder Permission Groups may be used to control access to all settings of 
the General Settings tab. The automatic cropping feature options are placed on the same tab so that 
enabling or disabling of automatic cropping can be controlled via permissions.

WDM Video Settings Sub-tab

The WDM Video Settings sub-tab allows you to configure the main set of options for the “WDM 
Video” capture source. When the “WDM Video” capture source is selected, live video from the 
currently selected video input of the currently selected WDM video capture device will be displayed 
in the multimedia window. This sub-tab is displayed only when the “WDM Video” capture source is 
selected.
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Device
Choose a specific WDM video capture device. Choices include all WDM video capture 
devices that are currently installed on this workstation. Live video from the currently selected 
video input will then be displayed in the multimedia window.

Select Video Input
Click this button to open the Select Video Input window from where you can select which 
video input to use.

Select Frame Format
Click this button to select a frame format. For some WDM devices, a window will open from 
where you can select the spatial resolution (number of pixels across and down) and the pixel 
format of captured video frames. For devices that do not allow you to adjust the frame format, 
the system automatically selects the frame format that has the largest spatial resolution and a 
pixel format with the most color information.

Adjust Picture
Click this button to adjust picture quality attributes such as hue, brightness and contrast. 
Depending on which WDM device you are configuring, a properties window will be displayed 
from where you can adjust these settings.

WDM Video Settings Sub-tab Procedures

The following procedures can be performed on this form.
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Configure WDM Video Settings

You should first complete this procedure using a test subject (person). Once you have optimized the 
settings for your physical environment, you shouldn't need to modify them unless you change the 
surroundings. Adjustments for an individual’s skin tone, hair color or clothing color can be made 
using the Image Processing window after the image has been captured. 

Before you begin, make sure that your camera and flash unit are powered on and properly configured 
for use.

1. In Multimedia Capture, on the Photo, Signature or Graphic tab, select “WDM Video” from the 
Capture Source drop-down list.

2. Click the WDM Video Settings sub-tab. (The [Show Admin Settings] button must be depressed 
in order to view the WDM Video Settings sub-tab.)

3. From the Device drop-down list, select the WDM video capture device that you want to 
configure settings for.

4. Click [Select Video Input]. The Select Video Input window opens.

5. In the Select Video Input window, choose which video input you want to use.

6. Click [Select Frame Format]. For some WDM devices, a window will open from where you can 
select the spatial resolution (number of pixels across and down) and the pixel format of captured 
video frames. For devices that do not allow you to adjust the frame format, the system 
automatically selects the frame format that has the largest spatial resolution and a pixel format 
with the most color information.

7. Click [Adjust Picture]. Depending on which WDM device you are configuring, a properties 
window opens, from where you can adjust these settings. From this window, adjust picture 
quality attributes such as hue, brightness and contrast.

8. If you want to save your settings so that they will be automatically displayed each time you select 
the WDM Settings sub-tab, click [Save User Defaults].

Note: If you want to use the factory-set values for these fields, click [Load Hardware Defaults] 
button. The sliders will be repositioned accordingly.

Capture an Image Using Live Video

1. In Multimedia Capture, on the Photo or Graphic tab, select either “FlashPoint/MCI Video” or 
“WDM Video” from the Capture Source drop-down list. 

Note: The [Show Admin Settings] button must be depressed in order to view the sub-tab.

2. Click the General Settings sub-tab.

3. If an image displays, click [Clear].

4. Physically position the test subject so their head and shoulders appear in the Multimedia Capture 
window. Click [Freeze].

5. Using your mouse, adjust the crop window to frame the subject. If the crop window is enabled, it 
displays as a rectangle over the image. For more information, refer to Enable Manual Cropping 
on page 142 and Resize the Crop Window on page 142.

6. If you want to retake the photo, click [Unfreeze] and repeat steps 4-5.

7. When you are satisfied with the image, click [OK]. 

8. If you want to adjust the photo quality, click [Process]. 
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FlashPoint/MCI Video Settings Sub-tab

The FlashPoint/MCI Video Settings sub-tab allows you to configure the main set of options for the 
“FlashPoint/MCI Video” capture source. When the “FlashPoint/MCI Video” capture source is 
selected, live video from the FlashPoint/MCI video device will be displayed in the multimedia 
window. This sub-tab is displayed only when the “FlashPoint/MCI Video” capture source is selected.

Video Board
Enter the name of the driver for your video capture board. The default is “FlashPoint.” Contact 
Technical Support for assistance if you have a video board that is not an Integral Technologies 
FlashPoint board.

Input Format
Select the format of the incoming video signal. Choices include:

• RGB - accepts separate inputs for the red, green and blue components.

• Composite - mixes the red, green and blue signals to produce a color image.

• SVideo - an analog video interface standard that separates the signal into two components, 
brightness and color.

Input Standard
Select the incoming video signal standard. Choices include:

• NTSC - the U.S. standard

• PAL - the European standard

Video Source
Select which video connector the incoming video signal is to be captured from. (Video 
connectors are numbered starting with zero.)
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Alternate Sync Mode
When this check box is selected, incoming video is routed through special video stabilizer 
circuitry in the FlashPoint video capture board. This allows you to capture video from video 
sources emitting “messy” video signals.

For example, video that comes from a VCR may constantly jump around on the screen if the 
VCR has a dirty play head, poor tracking or a worn-out tape in it. If the Alternate Sync Mode 
check box is selected, the video will stop jumping around and settle down to a stable picture, 
although there is usually a band of static (snow) at the bottom because some rows of the 
incoming video frames are lost during the stabilization process.

High Resolution Capture
When this check box is selected, you can capture photos at the maximum resolution of 640 by 
480 pixels instead of 320 by 240 pixels. (The high resolution photos will print on the cards at 
sizes larger than 0.6” by 0.8” with better quality, but at the price of a 300 to 400% increase in 
disk storage requirements.) To use high resolution capture you must:

• Use a Flashpoint board. Users with FlashPoint boards can now capture photos at a 
maximum resolution of 640 by 480 pixels instead of 320 by 240 pixels.

• Have a Desktop area that is at least 1024 by 768 pixels. Users who want to use high 
resolution capture must have a Windows desktop area that is at least 1024 by 768 pixels 
because a 640 by 480 pixel capture window and capture window user interface will not fit 
onto a 800 by 600 pixel desktop at the same time.

• Use a flash type other than “Universal.” To capture in high resolution, a flash type other 
than “Universal” must be used because Universal flash is capable of illuminating only one 
video field, i.e. every other row of pixels or 240 lines, within a high resolution video 
frame.

Flash Type
Select the type of flash unit connected. Your selection must match the jumper settings on the 
FlashPoint video capture board. For more information, refer to the your FlashPoint user guide 
for jumper information. Choices include:

• None - no flash unit connected. If you do not have a flash unit, you must make sure that the 
video capture environment contains sufficient light for the process. The maximum height 
is 480 when the capture is made in high resolution mode.

• Universal - triggers any standard photographic flash unit. The video capture board triggers 
the flash unit directly.

• CCD - flash trigger specifically for the Kodak CCD4000 camera. Instead of the flash being 
fired directly, the system triggers flash through the camera, a process called frame 
integrated flash. The maximum height is 480 when the capture is made in high resolution 
mode. If you choose this option, you must first configure your hardware for this capability.

When capturing with a universal flash or in low resolution capture mode, the maximum 
unscaled video frame height for the FlashPoint board is 240 lines of pixels.

Flash Field Delay
Enter the number of video fields you want the system to wait after it has fired the flash before 
it freezes (captures) video. This is used to synchronize a flash with the freeze-frame process so 
that frames will be captured while the light emitted from the flash is at its brightest.

Live video consists of pixels arranged in lines called fields. Each frame of video contains one 
even field and one odd field. The even field is composed of every odd numbered line of pixels, 
beginning with the first (top) line. The other lines in the frame constitute the odd field. 
Therefore, the incoming video signal alternates between the even and the odd fields at twice 
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the video frame rate (60 fields per second for the NTSC video standard, 50 fields per second 
for the PAL video standard).

FlashPoint/MCI Video I/O Settings Sub-tab

The FlashPoint/MCI Video I/O Settings sub-tab allows you to adjust the color, intensity and contrast 
of video captured with the “FlashPoint/MCIVideo” capture source. This sub-tab is displayed only 
when the “FlashPoint/MCI Video” capture source is selected.

Controls for Video Input
When this radio button is selected, the slider field settings adjust characteristics of the 
incoming video signal. These settings affect how the video is captured. The fields are board-
dependent. A dimmed field means that your video capture board does not support the 
corresponding characteristic. Possible values for all slider fields are in the range of 0 through 
1000.

Controls for Video Output
When this radio button is selected, the slider field settings adjust the output video display. 
These settings will affect only how the video is displayed. The fields are board-dependent. A 
dimmed field means that your video capture board does not support the corresponding 
characteristic. Possible values for all slider fields are in the range of 0 through 1000.

Flash Brightness
Increases or decrease the value of all color components for the flash.

Flash Contrast
Increases or decreases the differences in brightness between the image's brightest and darkest 
elements for the flash.
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Live Brightness
Controls the brightness for live video. Live video is darker with flash due to the reduced iris 
setting needed to prevent the flash from overpowering the camera. When the image is captured 
(by clicking the [Freeze] button), the controls switch over to the Flash Brightness setting.

Live Contrast 
Controls the contrast for live video. When the image is captured (by clicking the [Freeze] 
button), the controls switch over to the Flash Contrast setting.

Hue
Adjusts the aspect of a color that distinguishes it from other colors. This field is useful to 
achieve accurate skin tones in the image.

Red
Increases or decreases the global value of the image's red component

Green
Increases or decreases the global value of the image's green component

Blue
Increases or decreases the global value of the image's blue component.

Saturation
Adjusts the amount of color (intensity) to accommodate stronger and weaker input color 
signals.

Sharpness
Adjusts the image to be either more focused or more blurry.

Gain
Boosts the weak input signal or decreases noise coming from a strong but noisy source, 
helping to enhance details.

Gamma
Provides a nonlinear contrast adjustment. A higher gamma value produces a brighter image 
that has less contrast. A lower gamma value produces a darker image that has more contrast.

Offset
Moves the input signal level up or down without changing the signal size, helping to enhance 
details. This field is useful if your camera has a nonstandard output or has a direct current 
offset.

Load Hardware Defaults
Click this button to change the values of all slider fields to the factory defaults set by the video 
board manufacturer. (If you are using a FlashPoint board, this button loads the settings last 
saved with the FPG application that Integral ships with their boards.)

FlashPoint/MCI Video Settings Procedures

The following procedures can be used on this form.
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Configure FlashPoint/MCI Video Capture Settings

Notes: You should first complete this procedure using a test subject (person). Once you have 
optimized the settings for your physical environment, you shouldn't need to modify 
them unless you change the surroundings. Adjustments for an individual's skin tone, 
hair color or clothing color can be made using the Image Processing window after the 
image has been captured. 

Before you begin, make sure that your camera and flash unit are powered on and 
properly configured for use.

1. In Multimedia Capture, on the Photo, Signature or Graphic tab, select “FlashPoint/MCI Video” 
from the Capture Source drop-down list.

2. Click the FlashPoint/MCI Video Settings sub-tab.

Note: The [Show Admin Settings] button must be depressed in order to view the FlashPoint/
MCI Video Settings sub-tab.

3. In the Video section, choose the settings for your video source. For more information, refer to 
FlashPoint/MCI Video Settings Sub-tab on page 146.

4. In the Flash section, choose flash settings. For more information, refer to FlashPoint/MCI Video 
Settings Sub-tab on page 146.

5. If you want to save your settings so that they will be automatically displayed each time you select 
the FlashPoint/MCI Video Settings sub-tab, click [Save User Defaults].

6. Click the FlashPoint/MCI Video I/O Settings tab to display the FlashPoint/MCI Video I/O 
Settings sub-tab. (The [Show Admin Settings] button must be depressed in order to view the 
FlashPoint/MCI Video I/O Settings sub-tab.)

7. Select the Video Input radio button, then adjust the slider controls to optimize the incoming 
video signal. You can also do the same for video output (by selecting the Video Output radio 
button and adjusting the slider controls) to optimize the video display, although these settings are 
typically not adjusted.

Note: If you want to use the factory-set values for these fields, click [Load Hardware Defaults] 
button. The sliders will be repositioned accordingly.

8. If you want to save your settings so that they will be automatically displayed each time you select 
the FlashPoint/MCI Video I/O Settings sub-tab, click [Save User Defaults].

Use High Resolution Analog Video Capture

To capture analog video in high resolution, you must:

• Use a Flashpoint board. Users with FlashPoint boards can capture photos at a maximum 
resolution of 640 by 480 pixels instead of 320 by 240 pixels. (The high resolution photos will 
print on the cards at sizes larger than 0.6” by 0.8” with better quality, but at the price of a 300 to 
400% increase in disk storage requirements.)

• Have a Desktop area that is at least 1024 by 768 pixels. Users who want to use high resolution 
capture must have a Windows desktop area that is at least 1024 by 768 pixels because a 640 by 
480 pixel capture window and capture window user interface won’t fit onto a 800 by 600 pixel 
desktop at the same time.

• Use a flash type other than “Universal”. To capture in high resolution, a flash type other than 
“Universal” must be used because Universal flash is capable of illuminating only one video field 
(every other row of pixels or 240 lines) within a high resolution video frame.
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The size of the image/video display in the multimedia window varies depending on the Windows 
desktop area. The following applies:

• Windows desktop areas smaller than 800 by 600 pixels are no longer supported by the capture 
window.

• When the Windows desktop area between 800 by 600 pixels and 1024 by 768 pixels (as with the 
case with many laptops running mobile badging) the multimedia window is at a smaller size so 
everything will fit onto the screen. In this situation the image display area is 320 by 240 pixels 
and thus the user is unable to set analog video capture to high resolution mode. 

Note: Although high resolution analog video capture is not available when the desktop area is 
less than 1024 by 768 pixels, the High Resolution Capture check box remains visible. 
If an attempt to select high resolution capture is made, a message will be displayed that 
explains why it is not available.

• When the Windows desktop area is 1024 by 768 pixels or larger the capture window is now 
bigger so that the image display area (the area on the left hand side) and hence the multimedia 
window, can be 640 by 480 pixels, allowing for high resolution analog video capture. It will be 
320 by 240 pixels if the Flash Type is “Universal.”

To capture high resolution analog video:

1. Make sure that the desktop area is at least 1024 pixels by 768 pixels.

2. In Multimedia Capture, on the Photo, Signature or Graphic tab, select “FlashPoint/MCI Video” 
from the Capture Source drop-down list.

3. Click the FlashPoint/MCI Video Settings sub-tab.

Note: The [Show Admin Settings] button must be depressed in order to view the FlashPoint/
MCI Video Settings sub-tab.

4. Select the High Resolution Capture check box.

5. Make sure that “Universal” is not selected in the Flash Type field.

Scanner Settings Sub-tab

The Scanner Settings sub-tab allows you to configure how images are scanned. This sub-tab is 
displayed only when the “Scanner” capture source is selected.

Windows desktop area 
(pixels) Image display description

High resolution analog video 
capture supported

Smaller than 800 by 600 No longer supported No

Between 800 by 600 and 1024 
by 768

320 by 240 image display 
(smaller)

No

1024 by 768 and larger 640 by 480 image/video 
display (larger)

Yes, if Flash Type is not 
“Universal”
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Twain Source
Select the name of your scanner. In order for your scanner to be listed, you must have first 
attached the scanner to your computer, installed the device’s Twain driver software and 
configured it for use. For more information, refer to your scanner’s user guide. The Twain 
Source drop-down list will list the names of both scanners and digital cameras that are 
configured on your system.

Preview Scan
Includes the Do Preview Scan check box and the upper Show User Interface, Show Status, 
Number of Colors and Dots per Inch fields.

Do Preview Scan
When this check box is selected, you can scan the entire original page, then position the crop 
window and perform a final scan on only the area enclosed by the crop window. When this 
check box is not selected, you can bypass the preview scan and perform only a final scan. If 
you deselect this check box, you can ignore the other settings in the Preview Scan section.

Show User Interface
Select this check box to be allowed to utilize the Twain driver's default user interface instead 
of bypassing it.

Show Status
When this check box is selected and the Twain driver supports this option, a status bar is 
displayed showing the status of the scan. This does not apply if you are using your Twain 
driver's default user interface.

Dots per Inch
Specify the final scanning resolution, expressed in dots per inch.
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Number of Colors
Specify the final pixel type of the image to be scanned. 

Dots per Inch
Specify the resolution for preview scanning, expressed in dots per inch.

Final Scan
Includes the Use Crop Window check box and the lower Show User Interface, Show Status, 
Number of Colors and Dots per Inch fields.

Use Crop Window
When this check box is selected, you can perform a full (final) scan of the area enclosed by the 
specified crop window. When this check box is not selected, you can perform a scan using the 
default size set by the Twain driver. If the Do Preview Scan check box is selected, the crop 
window set there is used and this option has no effect.

Show User Interface
When this check box is selected, you can utilize your Twain driver’s default user interface. 
When this check box is not selected, your Twain driver’s default user interface is bypassed.

Show Status
When this check box is selected and your Twain driver supports this option, a status bar is 
displayed showing the status of the scan. This does not apply if you are using your Twain 
driver’s default user interface.

Number of Colors
Specify the final pixel type of the image to be scanned. 

Scanner Settings Sub-tab Procedures

The following procedures can be performed on this form.

Preview and Scan an Image

In most situations, this is the basic process for scanning an image. Before you proceed, make sure that 
your scanner hardware is attached to your computer and the scanner software is installed and 
configured for use.

1. In Multimedia Capture, click the Photo, Signature or Graphic tab.

2. Select “Scanner” from the Capture Source drop-down list.

3. Click the Scanner Settings sub-tab. (The [Show Admin Settings] button must be depressed in 
order to view the Scanner Settings sub-tab.)

4. Select the name of your scanner’s drive from the Twain Source drop-down list.

5. In the Preview Scan section:

a. Select the Do Preview Scan check box.

b. Enter values in the Number of Colors and Dots per Inch fields. It is recommended that you 
choose low values such as “16 Shades of Gray” and “75” dots per inch because the preview 
scan records the entire flatbed surface, performing a preview scan at a high resolution. A 
large amount of color information would require a huge amount of memory and hard disk 
space.
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6. Position the photograph on the scanner by placing the photo flush with the corner of the scanning 
surface. It the photograph is oriented incorrectly, the scanned image will appear crooked in the 
multimedia window. If this happens, to correct the problem, you’ll need to either rescan the 
original image or manipulate the image using the Image Processing window.

7. Click [Preview]. The entire contents of the scanning surface will be scanned and displayed in the 
multimedia window (the image in the window will look mostly blank except for a small photo).

8. In the Final Scan section:

a. Click the Use Crop Window check box.

b. Enter values in the Number of Colors and Dots per Inch fields. It is recommended that you 
choose high values such as “16.7 million (True Color)” and “300” dots per inch, ensuring 
that the final captured image is of the highest possible quality.

9. Move and resize the crop window to frame the image. If the crop window is enabled, it displays 
as a rectangle on the image. For more information, refer to Enable Manual Cropping on page 142 
and Resize the Crop Window on page 142.

10. Click [Scan]. The system scans the contents of the crop window.

11. To adjust the photo quality, click [Process]. For more information, refer to Image Processing 
Window on page 133.

Bypass the Preview Scan Step

The following procedure is useful if you have multiple hard copies that are the same size and you 
want to skip multiple preview scan steps. With this procedure, you preview the first hardcopy only.

1. In Multimedia Capture, click the Photo, Signature or Graphic tab.

2. Select “Scanner” from the Capture Source drop-down list.

3. Click the Scanner Settings sub-tab. (The [Show Admin Settings] button must be depressed in 
order to view the Scanner Settings sub-tab.)

4. Select the Use Crop Window check box.

5. Position a photograph on the scanner and click [Preview].

6. Move and resize the crop window to frame the photograph. If the crop window is enabled, it 
displays as a rectangle on the image. For more information, refer to Enable Manual Cropping on 
page 142 and Resize the Crop Window on page 142.

7. Deselect the Do Preview Scan check box.

8. Click [Save User Defaults].

9. Click [Scan]. The system scans the contents of the crop window.

10. To scan another hardcopy, place it on the scanner in the same position as the first hardcopy and 
click [Scan]. All subsequent scans use the crop window position you specified in step 6.

Notes: If you have a batch of photos to scan and all but a few of them are the same size, you 
can deselect the Use Crop Window check box just prior to scanning an odd-sized 
photo. Then move and resize the crop window and do the scan. After scanning the odd-
sized photo, reselect the Use Crop Window check box to return to using the crop 
window settings you saved as the default.

Many Twain drivers for scanners ignore dots per inch and number of color settings. For 
this reason, it is highly recommended that you select the Show User Interface check 
box.
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Digital Camera Settings Sub-tab

The Digital Camera Settings sub-tab allows you to configure how images are downloaded from 
digital cameras with the “Digital Camera” capture source. This sub-tab is displayed only when the 
“Digital Camera” capture source is selected.

Twain Source
Select the name of your digital camera. In order for your digital camera to be listed, you must 
have first attached the camera to your computer, installed the device’s Twain driver software 
and configured it for use. For more information, refer to your digital camera’s user guide. The 
Twain Source drop-down list will list the names of both scanners and digital cameras that are 
configured on your system.

Show User Interface
When this check box is selected, you can utilize your Twain driver’s default user interface 
instead of bypassing it. It is highly recommended that you select this option.

Show Status
When you select this check box and the Twain driver supports this option, a status bar is 
displayed showing the status of the scan. This does not apply if you are using your Twain 
driver's default user interface.

Digital Camera Settings Sub-tab Procedures

The following procedures can be performed on this form.
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Capture Digital Images

1. In Multimedia Capture, click the Photo tab or Graphic tab.

2. Select “Digital Camera” from the Capture Source drop-down list.

3. Click the Digital Camera Settings sub-tab. (The [Show Admin Settings] button must be 
depressed in order to view the Digital Camera Settings sub-tab.)

4. On the Digital Camera Settings sub-tab:

a. Select the name of your digital camera from the Twain Source drop-down list.

b. It is recommended that you select the Show User Interface check box. Otherwise, you will 
just download the first photo that is in the camera.

5. Click [Get Photo]. If an image displays, you need to click [Clear] first.

6. If the user interface for the digital camera software opens, adjust any settings. Otherwise, 
continue with the next step.

7. Take a picture of the cardholder/visitor. The image displays in Multimedia Capture.

8. Move and resize the crop window to frame the image. If the crop window is enabled, it displays 
as a rectangle on the image. For more information, refer to Enable Manual Cropping on page 142 
and Resize the Crop Window on page 142.

9. To adjust the image quality, click [Process].

File I/O Settings Sub-tab

The File I/O Settings sub-tab allows you to configure the default file import directory for the “File 
Import” capture source and the default file export directory for all of the capture sources.

Initial Import Directory
Enter the first place (drive and directory) in which to look when importing an image file into 
the database.
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Browse
Opens the Browse for Folder window from where you can select an initial import directory.

Export Directory
Enter the drive and directory into which image and signature files are saved when you click 
[Export].

Browse
Opens the Browse for Folder window from where you can select an export directory.

Prompt for Alternate Export Directory
When this check box is selected, you will be prompted with the standard File Save window 
when you click [Export]. The window is initialized to point to the file export directory. When 
this check box is not selected, the image is exported without the user being prompted for the 
export filename and path unless the file already exists.

File I/O Settings Sub-tab Procedures

The following procedures can be performed on this form.

Configure Multimedia Capture for File Import

1. In Multimedia Capture, on the Photo, Signature or Graphic tab, select “File Import” from the 
Capture Source drop-down list.

2. Click the File I/O Settings sub-tab.

Note: The [Show Admin Settings] button must be depressed in order to view the File I/O 
Settings sub-tab.

3. Complete the File Import section.

4. If you want to save your settings so that they will be automatically display, click [Save User 
Defaults].

Import a Supported Image File

1. In Multimedia Capture, on the Photo, Signature or Graphic tab, select “File Import” from the 
Capture Source drop-down list.

2. Click the File I/O Settings sub-tab.

Note: The [Show Admin Settings] button must be depressed in order to view the File I/O 
Settings sub-tab.

3. If an image or signature displays in the multimedia window, click [Clear]. Click [Open].

4. Select the file you want to import and click [Open]. The image displays in Multimedia Capture.

5. If the image is bitmapped and the crop window is enabled, adjust the crop window to frame the 
portion of the image that you want to save. To adjust the crop window, refer to Resize the Crop 
Window on page 142.

6. Click [OK] twice.
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Import a Multi-Resolution Image File

If the image file you are importing is a multi-resolution image the following dialog box will appear. 
Here you can choose what resolution you would like the image to be imported as.

Import a Non-Supported Image File

A large number of image file formats are supported. However, you may encounter a format that you 
wish to import that is not supported. Contact Technical Support for assistance if you would like 
support for a non-supported image file format to be added. This procedure details how to import an 
image that is in a file format that is not supported. For more information, refer to Supported Image 
Formats on page 159.

1. Save a temporary copy of the image in a supported format. Do this using a third party graphics 
editor/conversion application, preferably the one used to create the image. 
It is strongly suggested that you create the temporary file in a format that preserves original 
image quality. Here are a few guidelines to accomplish this:

• If the image is non-photographic and doesn’t look jagged when scaled larger (i.e., not a 
bitmap): 

– Use EMF if you can otherwise, use WMF or DXF. 

– Images created with CAD programs (like floor plans for buildings) and drawn images 
(like company logos) fall into this category.

• If the image is photographic or is known to have more than 256 colors:

– Use 16.7 million color BMP (i.e., 24-bits/pixel or true color BMP) 

– Use JPEG with a minimal amount compression if you have low disk space.

– Scanned images and images captured from a video camera or digital camera fall into 
this category.

• Otherwise, use 16 color or 256 color BMP (i.e., 4 or 8 bits/pixel BMP).

– The number of BMP colors should be greater than or equal to the number of colors used 
in the image. 

– Hand-drawn bitmapped images and photographic GIF images fall into this category.

2. Import the temporary file. For more information, refer to Import a Supported Image File on 
page 157.

3. Delete the temporary file.
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Supported Image Formats

The following table lists the image formats that you can import. If the file format you are working 
with is not identified by bits per pixel, refer to the Bits Per Pixel and Number of Colors Information 
on page 160 to determine color information.

Supported Image Formats

Format name
Common file 
extension(s)

Sub-formats supported (compression type/bits 
per pixel)

Adobe Photoshop PSD None/1, 8, 24

Auto CAD DXF

CALS Raster CAL CCITT Group 4/1

Delrina WinFax 
Group 3

FAX CCITT Group 3/1

Delrina WinFax 
Group 4

FAX CCITT Group 4/1

Encapsulated 
PostScript

EPS • PostScript Raster images/1,8

• Embedded TIFF images/(See TIFF format) 
Raster image information only, vector image 
information is ignored

FAX Group 3 FAX • 1-Dimensional Group 3 without header (raw)/1

• 2-Dimensional Group 3 without header (raw)/1

FAX Group 4 FAX CCITT Group 4 without header (raw)/1

GEM Image IMG NONE/1

IOCA or IBM Image 
Object Content 
Architecture

ICA • MO:DCA wrapper with embedded CCITT 
Group 3/1

• MO:DCA wrapper with embedded CCITT 
Group 4/1

• No MO:DCA wrapper/1

JFIF or JPEG File 
Interchange 
Format

JPG/JIF • Progressive JPEG/8 (YUV 4:0:0 grayscale), 
24 (YUV 4:4:4, 4:2:2, 4:1:1 color)

• Non-progressive JPEG/8 (YUV 4:0:0 
grayscale), 24 (YUV 4:4:4, 4:2:2, 4:1:1 color)

JPEG Tagged 
Interchange 
Format

JTIF Non-progressive JPEG/8 (YUV 4:0:0 grayscale), 
24 (YUV 4:4:4, 4:2:2, 4:1:1 color)

Kodak FlashPix FPX • NONE/8, 24

• JPEG

Kodak Photo CD PCD NONE/8, 24

LEAD CMP CMP • Progressive CMP/1,8,24

• Non-progressive CMP/1,8,24

Macintosh Pict 
Format

PCT NONE/1, 4, 8, 24
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MacPaint MAC NONE/1

Microsoft Paint MSP NONE/1

OS/2 Bitmap BMP 1.x and 2.x formats/1, 4, 8, 24

Portable Network 
Graphics

PNG PNG/1, 4, 8, 16, 24, 32

SUN Raster 
Format

RAS NONE/1, 4, 8, 24, 32

TIFF or Tagged 
Interchange File 
Format/Multipage 
TIFF

TIF/MPT • Uncompressed/1, 2, 3, 4, 5, 6, 7, 8, 16, 24, 32

• RLE/1, 2, 3, 4, 5, 6, 7, 8, 16, 24, 32

• CCITT/1

• 1-dimensional CCITT Group 3/1

• CCITT Group 4/1

• JTIF (Non-progressive JPEG)/8 (YUV 4:0:0 
grayscale), 24 (YUV 4:4:4, 4:2:2 or 4:1:1 color)

Truevision TARGA TGA • Uncompressed/8, 16, 24, 32

• RLE/8, 16, 24, 32

Windows Bitmap BMP/DIB • Uncompressed/1, 4, 8, 16, 24, 32

• RLE/1, 4, 8

Windows 
Enhanced Metafile

EMF • Uncompressed/1, 4, 8, 16, 24, 32

• RLE/1, 4, 8

Windows Metafile WMF • Uncompressed/1, 4, 8, 16, 24, 32

• RLE/1, 4, 8

WordPerfect 
Format 

WPG RLE/1, 4, 8 (Raster image information only, vector 
image information is ignored)

Zsoft PCX / 
Multipage PCX

PCX/DCX RLE/1, 4, 8, 24

Bits Per Pixel and Number of Colors Information

Bits per 
pixel

Number of 
colors Description

1 2 Monochrome

2 4 CGA

3 8

4 16 EGA/VGA

5 32

Supported Image Formats (Continued)

Format name
Common file 
extension(s)

Sub-formats supported (compression type/bits 
per pixel)
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Notes About Specific Image Formats

• EPS & WPG Image Formats

OnGuard provides partial support for the EPS (Encapsulated PostScript) and WPG (WordPerfect 
Format) formats. While EPS and WPG files can contain raster (bitmap) and vector (text, line, and 
shape drawing commands) information, OnGuard applications can only read raster information. 

If you want to import EPS or WPG files that contain vector information you should convert the 
files to EMF (Windows Enhanced Metafile) or WMF (Windows Metafile) format and import 
those files instead.

• EMF, WMF, & DXF Image Formats

EMF and WMF files contain raster (bitmaps) and/or vector (text, line, and shape drawing 
commands) data. DXF files contain vector data only.

OnGuard supports EMF, WMF, and DXF file import. This means that:

– Badge layout graphics, cardholder photos, and cardholder signatures can be imported as 
WMF, EMF, and DXF files.

– Vector images can be imported and remain vector images instead of being converted to 
bitmaps. However, the signature settings, image processing, chromakey, and the crop 
window are disabled when a vector image is imported. 

• GIF & LZW Image Formats (Not Supported)

As the result of Unisys licensing the LZW compression technology, GIF (Graphics Interchange 
Format), and LZW compressed TIFF formats are not supported.

6 64

7 128

8 256 256 color VGA/256 gray levels

16 65,536 High Color

24 16,777,216 True Color

32 16,777,216 True Color with 8 bits of alpha information. 
The alpha information is ignored.

Bits Per Pixel and Number of Colors Information (Continued)

Bits per 
pixel

Number of 
colors Description
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APPENDIX B Keyboard Hot Keys and Shortcuts
This section lists the keyboard hot key (Alt+) and shortcut (Ctrl+) assignments for each menu item in 
BadgeDesigner.
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Layout Menu (Alt+L)

Edit Menu (Alt+E)

Menu Item Hot Key Combination Keyboard Shortcut

New Alt+L+N Ctrl+N

New From Template Alt+L+M Ctrl+M

Open Alt+L+O Ctrl+O

Gallery Alt+L+G Ctrl+G

Close Alt+L+E Ctrl+F4

Save Alt+L+S Ctrl+S

Save As Alt+L+A Ctrl+A

Update Database Field List Alt+L+U Ctrl+U

Log On Alt+L+L Ctrl+L

Change Password Alt+L+C

Log Off Alt+L+L Ctrl+T

Exit Alt+L+X Alt+F4

Menu Item Hot Key Combination Keyboard Shortcut

Cut Alt+E+U Ctrl+X

Copy Alt+E+C Ctrl+C

Paste Alt+E+P Ctrl+V

Delete Alt+E+D Del

Insert Alt+E+I

Rename Object Alt+E+R F2

Object Text Alt+E+T F4

Select Graphic Alt+E+G

Select Previous Alt+E+V Shift+Tab

Select Next Alt+E+X Tab

Select All Alt+E+S Ctrl+Keypad 5

Deselect All Alt+E+L Shift+Esc

Move Forward Alt+E+F Ctrl+Minus

Move Back Alt+E+B Ctrl+Plus
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Edit Menu (Alt+E)
Move to Front Alt+E+N Alt+Minus

Move to Back Alt+E+K Alt+Plus

Menu Item Hot Key Combination Keyboard Shortcut
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Insert Menu (Alt+E+I)

View Menu (Alt+V)

Toolbars Menu (Alt+V+T)

Menu Item Hot Key Combination Keyboard Shortcut

Barcode Object Alt+E+I+B

Cardholder Photo Object Alt+E+I+P

Cardholder Signature Object Alt+E+I+S

Circle Object Alt+E+I+C

Ellipse Object Alt+E+I+E

Graphic Object Alt+E+I+G

Magnetic Stripe Object Alt+E+I+M

Rectangle Object Alt+E+I+R

Round Rectangle Object Alt+E+I+D

Smart Chip Contacts Object Alt+E+I+H

Text Object Alt+E+I+T

Menu Item Hot Key Combination Keyboard Shortcut

Toolbars Alt+V+L

Status Bar Alt+V+S

Layout Properties Alt+V+P

Object Properties Alt+V+O

Options

Menu Item Hot Key Combination Keyboard Shortcut

Layout Alt+V+T+L F7

Drawing Alt+V+T+D F8

General Formatting Alt+V+T+G F9

Graphic Formatting Alt+V+T+R F10

Text Formatting Alt+V+T+T F11

Barcode Formatting Alt+V+T+B F12
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Window Menu (Alt+W)
Window Menu (Alt+W)

Help Menu (Alt+H)

Menu Item Hot Key Combination Keyboard Shortcut

Cascade Alt+W+C

Tile Horizontally Alt+W+H

Tile Vertically Alt+W+T

Close All Alt+W+L

Switch Panes Alt+W+S F6

Menu Item Hot Key Combination Keyboard Shortcut

Contents Alt+H+C

Search Alt+H+S

Send Feedback Alt+H+F

About BadgeDesigner Alt+H+A
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